ran update to current svn, not showing a change



  • I noticed this the other day, on the fog primary I run the update as I always have to move to the current svn trunk. However the version number hasn’t changed. My storage node reports just fine. Where else can I check to see if a new svn has been applied other than the cloud image or the system activity window? My primary reports 6179 and the node says its 6261.

    I’ve tried removing the svn directory as a whole and letting it download everything again as well as using wget, extracting, and installing.

    Ubuntu 14.04
    Original install command:

    svn co https://svn.code.sf.net/p/freeghost/code/trunk ~/svn/trunk
    cd ~/svn/trunk/bin
    ./installfog.sh
    
    

    Update command:

    cd ~/svn/trunk/bin
    svn up
    cd bin
    ./installfog.sh
    

  • Senior Developer

    Amazing what I know sometimes, even if I can’t seem to do anything right today :)



  • @Tom-Elliott said:

    @Scott-B Is it possible that the links are causing weird things?

    Can you delete all webroot paths for fog?

    rm -rf /var/www/fog
    rm -rf /var/www/html/fog
    

    Then rerun the fog installer?

    Thanks Tom, that did the trick.


  • Senior Developer

    @Scott-B Is it possible that the links are causing weird things?

    I create a link to the fog folder in (where applicable):

    /var/www/html/fog/ (yes recursive i know)

    If it’s debian/ubuntu with /var/www/html, I create a link to:
    /var/www/

    This is so things can be left alone (clients where you have a webroot of / and client is looking at /fog/) This way you don’t have to update all clients to use the new webroot methods.

    Can you delete all webroot paths for fog?

    rm -rf /var/www/fog
    rm -rf /var/www/html/fog
    

    Then rerun the fog installer?


  • Moderator

    @Scott-B I guess we should start with the basics. How are you determining the version? Are you going through the entire installation process when you update?



  • I changed a few things around and ran both on the primary and the storage node. Exact same commands. Storage node updated. Primary still on 6179.

    Install:

    cd /root
    mkdir fogsvn
    cd fogsvn
    mkdir trunk
    cd trunk
    svn checkout https://svn.code.sf.net/p/freeghost/code/trunk /root/fogsvn/trunk
    cd /root/fogsvn/trunk/bin
    ./installfog.sh
    

    Update:

    cd /root/fogsvn/trunk
    svn up
    cd bin
    ./installfog.sh
    

    I don’t get why 1 updates fine and the other doesn’t when the same commands are used. Could me something little I’m just not seeing. If move to the trunk folder and do a svn up, both say “At revision 4792”.


  • Senior Developer

    @Wayne-Workman you’re absolutely correct.

    I make changes quite often, but it’s not that often I make any changes to the bin directory.

    Whatever directory you’re in, and up the tree, will be updated when doing that svn up method.

    For example:

    cd /opt/fog/svn/trunk/packages/web/lib/fog
    svn up
    

    Will only update files in the packages web lib fog and up (if there are).


  • Moderator

    @Scott-B said:

    cd ~/svn/trunk/bin
    svn up
    cd bin
    ./installfog.sh

    That’s your problem I think. Don’t go into the bin directory to update. that only updates the directory you’re in I think.

    Instead, go first to ~/svn/trunk and then svn up.


Log in to reply
 

357
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.