Missing d1.mbr when upload new image -svn 6120



  • I need a little help from my fog friends. :smiley:
    Upgrade my svn to 6120 version this morning and upload 2 new image from 2 different computers (both using mbr: sda1=winre, sda2=C:, sda3=swap, sda4=/).
    When i did a deploy, i got:

    Image Store Corrupt: Unable to locate MBR (restorePartitionTablesAndBootLoaders)
    

    Looking at /image folder and comparing with other images (uploaded from 6110 version), this upload is missing d1.mbr file.

    My image settings still the same (6110=6120):
    OS: Linux
    Type: Single Disk Resizable
    Part: Everything
    Compression: 6

    maybe this upload process has left something behind. :wink:

    Editing:
    If this can help: running the upload task in debug mode, I could see that the variable mbrfile and imgType are empty.
    My apologies but i can’t put any screenshot right now.



  • @Tom-Elliott It’s working now!!
    The upload process took “horrible” 15 minutes, and i was forced to drink a coffee…(everything is a reason for a coffee :) )
    After uploaded a new image, d1.mbr was created.
    The image was sucessfully created and deployed.
    Thanks again.


  • Senior Developer

    @Tom-Elliott I’m also going to try to see if I can just generate the partition table from the requisite sfdisk file if the mbr is missing but the sfdisk file exists.


  • Senior Developer

    @Thiago Found, tested, and fixed.

    Please upgrade again and retest. Yes, I know, you have to reupload the image.



  • @Tom-Elliott
    Dual Boot Image (Win10/Debian8) using mbr bios.
    There are 4 partitions and my settings in fog are:

    • OS: 50 - Linux
    • Type: Single Disk Resizable
    • Partition: Everything
    • Compression: 6

    It worked at 6110 version. (same computer and settings)


  • Senior Developer

    What type of image is this?



  • The problem still in 6124 version


Log in to reply
 

804
Online

38711
Users

10542
Topics

99799
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.