Imaging Issues After Migration



  • I have finished migrating to a new physical server. All is good until it is time to download an image. I get an error related to partition syntax. Then it goes through a list of other errors related to partitions. I have verified that all of the images from the /images directory were moved off of the old server to the /images directory of the new server. I am not sure what I am missing. Anyone else have this issue?


  • Senior Developer

    @atarone where is 1.3.0 and why don’t I know about it? 1.3.0 is what we will label the latest trunk when we release but it has not reached that point yet. I’d have loved to have released by now but seeing as 1.3.0 will be the last of the php series, I’m trying very hard to make this version as stable as I can before it releases. I am not going to say yes it supports this or that thing because it isn’t guaranteed to work the same way for everybody. What I will say is if you need the support the latest development versions will most likely suit you better than anything else.


  • Moderator

    Here is the process for the upgrade to trunk. https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk

    Understand that 1.3.0 stable has not been released yet. So there may be some instability in the current trunk build. But the more people we can get into the trunk and reporting issues the quicker the devs will feel confident about calling the trunk build stable.

    The trunk build does manage uefi systems MUCH better than the kind of support 1.2.0 has.



  • @Sebastian-Roth Well I got it working. There was a problem with the hard drive in the PC. I changed it out and it works great. Sorry for wasting everyone’s time. Probably should have checked for the obvious. You did mention that the latest FOG Trunk is available as well as FOG 1.3.0, where can I download those? Does FOG 1.3.0 support UEFI booting and imaging?

    Thanks again!


  • Developer

    @atarone It looks like FOG does not find the hard drive on your client machine. So the commands used (e.g. fogpartinfo) just mess up. There is a check in the scripts but looks like this is not catching your case. I am really wondering what has changed when migrating from one server to the other. I am sure this has all worked on the old system. But we need more information to make sure what’s wrong. Could you please run debug download task. Then see if you have any errors earlier on and post another picture for us here.



  • @george1421 Not a problem…I should have been more descriptive in the beginning. I uploaded a picture to the post of the output I am getting




  • Developer

    Sounds like you’ve done a good job migrating to the new server. So to figure out what’s wrong we best should have a picture of the error message you see!


  • Moderator

    @atarone Ok great. (sorry about the long way to get to this point, but sometimes there is no way to know what the poster has already done)

    Now what I would like you to do is capture the error messages about the format. If you have a mobile phone snap a picture to capture the error and post it here so the devs can take a look at the exact spot where the error begins.



  • @george1421 I apologize, yes that has been done. I migrated the database and imported the old database into the new server’s database. So, when I log into the GUI all of my hosts are listed under the Host section and all of my images are listed under the Image section. The image is mapped to the corresponding Host in the GUI.


  • Moderator

    @atarone OK, understood you never upgraded. The reason why I ask is that the image format that is captured has changed a bit and that might be the cause of the error. But that is a non-issue now.

    Its still not clear if you setup the management interface to use the images you copied over from the old fog server. Migrating to a new fog server requires a few steps. One is to move the files, the second is to either clone the database or recreate the configuration in the new server that will use these copied files.



  • @george1421 The old server was never upgraded. It was brought online about 6 months ago as a test and now that we like we moved it to a better server.


  • Moderator

    @atarone Lets make sure I understand your setup.

    You had a running and functioning FOG running on 1.2.0.
    You created a new fog server on new hardware
    You copied the files from the old server to the new server.

    Now to be able to image a computer with the new fog server you need to create a image record using the FOG management gui right? From there you created a host and assigned it to an image and storage node, right?



  • @george1421 I probably did not do that. How is that done?


  • Moderator

    @atarone you copied the files from the old server to the new server using the same version of fog. Did you recreate the image records with the same information?

    This old server, was it an original install of FOG or was it ever upgraded from an earlier release.



  • The version of FOG i just installed is 1.2.0. The old server was running 1.2.0. I have not upgraded to the FOG trunk.


  • Developer

    I guess it’s FOG trunk but not the very latest version. Tom has changed and fixed things here and there. Probably try upgrading to current trunk and running the installer again. If you still see issues please post a picture so we know exactly what error you see. If the errors flood down the screen too fast you can select ‘debug’ when starting the task in the web gui. This way you can step through it.


  • Moderator

    OK lets get a bit more information because I think the answer is hidden in your post.

    What version of fog did you just install?
    Have you upgraded to the fog trunk (i,.e. pre 1.3.0 )?
    What version of fog did you copy the images from (i.e. old server)?

    If you moved from 0.30 to 1.2.0 the image format has changed between the releases. As well as between 1.2.0 and 1.3.0.


Log in to reply
 

392
Online

38729
Users

10555
Topics

99942
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.