NIC Intel 82579LM PXE issue



  • We are having a problem with a laptop that has a Intel 82579LM NIC. Was wondering if anyone has any experience with problems uploading or downloading with this NIC? Other NIC’s work fine with Fog. In the compatibility page, it says the network is [fail], but the hard drive is [pass].



  • Running a multicast in debug mode:
    Timeout notAnswered=[0,1] notReady=[0,1] nrAns=0 nrRead=0 nrPart=2 avg=30079 bytes= 39 033 904 re-xmits=0000000 (0.0%) slice=1024 73 709 551 615 - 0

    But both clients running with ~60MB/min



  • Thank you astrouga! I downloaded the new Kernel, but multicast is still very slow. max 70/MB per Minute in a Gbit network. Unicast runs well. Trying other Kernels dont fix the problem…

    Any idea why only multicast connection is slow and unicast runs well?

    System:
    Dell Optiplex 790
    Tested Kernels: 3.4, 3.3, 2.6
    Gbit Switch
    same VLAN

    Fog 0.32 Syslinux FIX in a Virtual Box.

    regards



  • Try this one.

    [url]http://www.filedropper.com/bzimage34[/url]

    I think that is the image file. If you have issues, let me know.

    astrouga



  • I have the same Problem on Intels 82579LM, speed slows down to 60MB/min by using multicast. Can someone please upload the Kernel 3.4 again? All links are down.

    regards


  • Banned

    This post is deleted!


  • [quote=“gballane, post: 3954, member: 1226”]I just wanted to see if anyone had a chance to T/S this? Getting anxious due to deadlines![/quote]
    Sorry I missed these posts. I’ve only seen this issue when I am trying to dump a partition to a drive that is smaller than the partition. For example, if I imaged an 80 GB partition and tried to put that image on a 60 GB drive, I would get that error.

    The trick to make all of you images work on all of your machines (well at least part of the trick) is to shrink your windows partition before you image it. Then you can extend it when you install. My images all “extend” via a vbscript after the imaging process is complete and sysprep is running.

    astrouga.



  • [quote=“rakarn, post: 4739, member: 921”]Any way I can get this kernel everytime i go to your link it doesnt give me anything to download, no link just a page asking me to signin or upload?[/quote]
    Sorry about the dead link. I didn’t know there was a time limit to the post. I have reloaded it.



  • Any way I can get this kernel everytime i go to your link it doesnt give me anything to download, no link just a page asking me to signin or upload?



  • I just wanted to see if anyone had a chance to T/S this? Getting anxious due to deadlines!



  • Same error message: Can’t have partition outside the disk…

    A message does flash really fast about an unsupported BIOS version… but I’m not sure if that is actually the problem we’re having.



  • I tinkered with this some more. With the bzimage34 kernel… when it tries to push down to the client, it checks hard disk and says “image cannot be outside of disk” or something to that affect. Went into the client and it had a TON of partitions… more than the 250 GB hard drive… it was like 1TB+. I pulled out the HDD and reformatted in an external enclosure. Trying the push down again to the client.



  • We didn’t try other machines… We had to restore it to the old kernel so that we could continue working!

    Hopefully, we can make some progress next week. Thanks for your help.



  • OK, I’ll get back to you next week. I’ve got to rolll for now. Sorry that didn’t work out for you. Does the kernel work for any of your other systems?

    Follow-up if you make any progress.



  • No good… when uploading, getting partition errors. Tried to push it down, failed… said it pushed the image down really quick and finished in seconds.

    We are working with a Fujitsu T731.



  • drum roll please…



  • Will try it right now… stand by.



  • The size is fine. It should not have a file extension. Did you try using it? You need to put that file in /tftpboot/fog/kernel. Then associate your machine with that kernel. Then you can try an imaging task with it.



  • I tried downloading your kermel but it had no file extension and was only 10.4 MB where as the 3.4 kernel is 96 MB

    I also tried just using the 3.4 kernel but when I got to the step of creating the bzImage I got this error:

    make[1]: Nothing to be done for all'. make[1]: Nothing to be done forrelocs’.
    CHK include/linux/version.h
    CHK include/generated/utsrelease.h
    CALL scripts/checksyscalls.sh
    CHK include/generated/compile.h
    VDSOSYM arch/x86/vdso/vdso32-int80-syms.lds
    VDSOSYM arch/x86/vdso/vdso32-sysenter-syms.lds
    VDSOSYM arch/x86/vdso/vdso32-syms.lds
    LD arch/x86/vdso/built-in.o
    LD arch/x86/built-in.o
    CC drivers/scsi/lpfc/lpfc_scsi.o
    cc1: warnings being treated as errors
    drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bg_setup_bpl’:
    drivers/scsi/lpfc/lpfc_scsi.c:1900:11: error: unused variable ‘rc’
    drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bg_setup_bpl_prot’:
    drivers/scsi/lpfc/lpfc_scsi.c:2037:11: error: unused variable ‘rc’
    drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bg_setup_sgl’:
    drivers/scsi/lpfc/lpfc_scsi.c:2256:11: error: unused variable ‘rc’
    drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bg_setup_sgl_prot’:
    drivers/scsi/lpfc/lpfc_scsi.c:2386:11: error: unused variable ‘rc’
    make[3]: *** [drivers/scsi/lpfc/lpfc_scsi.o] Error 1
    make[2]: *** [drivers/scsi/lpfc] Error 2
    make[1]: *** [drivers/scsi] Error 2
    make: *** [drivers] Error 2



  • This is kernel 3.4 with the addition of the latest NIC driver, though I think it just recompiled the driver itself. Still, it solved my issues. You should be able to use it for all of you machines. Test it out though and let us know. It would be great to know make/model with successes or failures.

    You know how to specify a kernel for a host, right? If not, I am sure it is in the wiki or forum somewhere. Otherwise, ask and I’ll look.


Log in to reply
 

477
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.