SOLVED Adding Needed Repository............. Failed!

  • Hi Guys,

    I know this has come up before and I have trawled the forum and the internet in general looking for answers before I took to posting this issue again so apologies if this a bit like a broken record. Unfortunately none of the proposed solutions have resolved the issue.

    Heres the thing, I am trying to install FOG 1.3.0 SVN trunk onto my Ubuntu 14.04.2 server so that I can test it with Windows 10 deployments ready for this years refresh. I am hitting the error at the beginning of the install of FOG that states - Adding Needed Repository… Failed!

    The server is a clean Ubuntu 14.04.2 install running as a VM on VMware. It has already been operating as a web server so has Apache and MySQL already setup on it. Not sure if this is the issue? I have installed python-software-properties and software-properties-common. I am not behind a proxy. I used the wget method to retrieve the trunk as I was getting issues with SVN due to a self signed certificate on my firewall.

    Anyone got any ideas?

    Much appreciated 🙂


  • Moderator

    Should be fixed in the very latest version!

  • Hey,

    Okay so I’m updating this so that any other users hitting this problem under these circumstances can hopefully get to a resolution.

    So it turns out that the problem is my self signed certificate. So I added the cert to the ca-certificate store and included it as trusted. This had no effect. SVN and Git methods were still rejected. In fact SVN just hangs. So tried SVN with --non-interactive --trust-server-cert options and it still refused to connect.

    In the end I worked round Git by running the following command to configure it to basically not verify SSL certs:

    git config --global http.sslVerify false

    This actually worked in that it allowed me to clone the Git repo. Success, or so I thought 😕

    I ran the install from the cloned repo and hit a different error:

    • Adding needed repository…/lib/common/ line 456: /var/log/fog_error_5937.log: No such file or directory
      …/lib/common/ line 457: /var/log/fog_error_5937.log: No such file or directory
      …/lib/common/ line 458: /var/log/fog_error_5937.log: No such file or directory
      …/lib/common/ line 460: /var/log/fog_error_5937.log: No such file or directory
      …/lib/common/ line 461: /var/log/fog_error_5937.log: No such file or directory
      …/lib/common/ line 462: /var/log/fog_error_5937.log: No such file or directory
      …/lib/common/ line 463: /var/log/fog_error_5937.log: No such file or directory
      …/lib/common/ line 464: /var/log/fog_error_5937.log: No such file or directory

    So any ideas on this one?



    PS: Thanks for all your efforts so far with this one Tom. Well beyond the call of duty mate. Nice one.

  • Please check your chat messages.

    There are only a few cases that I know of that causes this problem. Unfortunately which one is not very simple to determine.