FOG Does not Restore the 100MB Partition for Windows 7 Image



  • Hi everyone. Jumping right into it…
    [LIST]
    []FOG 0.32 installed on Debian 6.0.4
    [
    ]I have a Win7 Machine fully sysprepped and ready to go
    []I have installed FOG and successfully captured a computer as is (test laptop; single partition, resizeable), made changes and then restored back, so FOG is working
    [
    ]I am using a Dell OptiPlex 755
    []I had to recompile the kernel to use kitchen sink to not get a fuzzy screen when using bzImage
    [
    ]I have successfully captured a Win7 image with multiple partitions, single disk and restored it to the same sized disk (160GB) and larger (250GB)
    []The odd part about the multiple partition restore is it made the partitions larger 101MB to 105MB at most
    [
    ]I have (from what I can tell) successfully uploaded a Win7 image with the 100MB partition as a single partition, resizeable. It distinctly shows two partitions being uploaded to the server.
    [/LIST]
    ls /images/singlepart
    -rw-r–r-- 1 root root 8.4M Apr 23 09:33 rec.img.000
    -rw-r–r-- 1 root root 8.1G Apr 23 09:53 sys.img.000
    [LIST]
    []I have the host machine that the image was uploaded from set as Win7
    [
    ]I have the destination machine that the image is to be deployed to set as Win7
    []I have deployed the image, but only /dev/sda2 partition seems to come down
    [
    ]I have tried restoring this single partition upload from a 160GB drive to an 80GB drive, another 160GB drive and a 250GB drive with no success on any of the systems
    []Upon booting I receive a message “No Operating System”
    [
    ]Booting into a live CD I see a blank section of 101MB before the actual partition
    [*]I have quick wiped several times to destory the MBR and fully rewrote the disk overnight 4 times
    [/LIST]
    Does anyone have any idea of what is going on here? What else can I troubleshoot with this? What setting am I missing?
    At the time of this writing I will be reinstalling Debian 6.0.4 on another server. I’m hoping a fresh install of everything will fix whatever is borked, but I could sure use all the help I can get.



  • Hmmm, interesting. I haven’t had any problems using a single resizable partition. I wonder if that’s because all of our machines still have the 100mb partition still in place when they are imaged, and perhaps the image just replaces the OS partition instead of the system reserved.

    Our machines are all typically the Dell Latitude series (couple of Precisions, but they work too), and the master image came from a modified e6510 build (it’s been converted to a VM, since).



  • Yeah, perhaps. I’ve just given up on the “single disk” for now. I’m going to test out the latest .33 beta trunk tomorrow. Looks like the NTFS resizable option is a work in progress though:

    [url]http://freeghost.svn.sourceforge.net/viewvc/freeghost/trunk/?view=log[/url]

    Cheers,

    astrouga



  • That’s odd Astrouga, maybe it’s dependent on the machines? I’ve never once had a problem with it, but as you said, I could be one of the rare ones from the sounds of it. Thanks for the info



  • I use “Multiple Partition - single disk”, regardless of the number of partitions (one or more) and it always works. “Single Disk - NTFS Resizable” is broken though. I have tried many, many different Windows 7 stand-alone installs and it fails. I don’t think I have ever gotten it to work. Truthfully, given the number or people claiming that it fails, I don’t think it is reliable. I wouldn’t recommend it until .33 comes out. The developers are definitely aware of problems that I’ve had with it and are addressing it in the next release.



  • Depending on your install of Windows 7 will determine what image type you can select. Most of the major manufacturers have that little recovery partition that is preloaded into the OEM versions of Windows 7 that comes with the machines, therefore you either have to CAREFULLY remove the recovery partitions (there are many guides on the internet detailing this, but use with caution) or upload as Multiple Partition - Single Disk. However, if you are using a stand-alone install of Windows 7, the Single Disk - NTFS Resizable works just fine.

    Again, I want to echo if you’re considering deleting the recovery partition to be very careful in doing so, depending on the OEM install, that partition may also contain the Bootmgr and other necessary startup files, so proceed with caution.



  • My experience is similar to Bounty’s. I have had limited success using the Single / Resizeable but the multiple partition always works so I don’t waster my time fooling with the Single option.



  • We have been able to use the NTFS Single Resizeable with our Dell computers by reinstalling Windows 7 scratch, delete all of the existing partitions, and let the Windows installer create all of the partitions including the 100MB partition. We were not able to use the NTFS Resizeable with the Pre-loaded OS that Dell installs on the new computers. I am not sure if that helps or not.


  • Moderator

    I have always used 100mb + rest of disk (2 partitions) and set image to: Windows 7 | Single Partition (ntfs Resizable)


  • Moderator

    I have given up trying to get windows 7 to work with the resizable image type. I use the multiple partition - single disk. It still compresses the image and only stores actual data, so if a full load uses 70GB in windows, the image is around 50GB on the server.



  • Draylorre, did you get this figured out?

    I have imaged Optiplex 755’s running Windows 7 many times with and without the 100MB system partition. I have never had any issues when I use the “Multiple Partition - Single Disk” option.

    –astrouga



  • I would guess that the 100MB partition growing to 105MB might be related to the [FONT=Ubuntu][COLOR=#333333][B]FOG_UPLOADRESIZEPCT[/B] setting under[/COLOR][/FONT][B] Other Information > FOG Settings > General Settings. [/B]It’s default setting of 5% seems like it may be non-conicidental in this case.



  • I had similar issues with my Dells.
    What I do:

    -Prep entire machine.
    -Boot from Win7 DVD
    -Delete the 100MB partition
    -Upload using Multi Partition

    Works everytime



  • [quote=“Draylorre, post: 3023, member: 981”]
    [LIST]
    [*]Upon booting I receive a message “No Operating System”[/LIST][/quote][LIST]
    [/LIST]
    For the life of me I’ve never been able to get the Single Partition to work with Windows 7. I’ve always had to use the Multi Partition- Single Disk only.

    I’m just not happy with the size of the image file that it makes.



  • I’m not sure what the issue is? Does it matter that the partition is slightly differently sized?

    Windows 7 should be captured using a multi-partition image type, not single partition - as it has multiple partitions. I believe the one that most use is “[FONT=Verdana][COLOR=#333333]Multiple Partition Image - Single Disk (Not resizable)”.[/COLOR][/FONT]


Log in to reply
 

434
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.