Fog 1.2. FOGFTP: Login failed



  • I just upgraded a 0.32.server to 1.2, and I cannot seem to figure out why I cannot get ftp working. When displaying all the images in the web interface, I noticed that it gives me the “FOGFTP: Login failed” message for all the images. I also cannot ftp to the server from another linux box, says the password is incorrect. I have gone through the Wiki …(https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP)

    • I have disabled the Firewall

    • I made sure to change the rights on the images directory (sudo chown -R fog:root /images)

    • All the mentioned places below have the same username and password
      The “fog” user for the web interface
      Web Interface -> Storage Management -> My storage node -> Management Username & Management Password
      Web Interface -> FOG Configuration -> FOG Settings -> TFTP Server -> FOG_TFTP_FTP_USERNAME & FOG_TFTP_FTP_PASSWORD
      The local ‘fog’ user on the Fog Server

    • I also manually edited “/var/www/fog/lib/fog/Config.class.php” to reflect the same values.

    Any ideas as to what could be going wrong? It is acting like the password I am defining is not actually being set somehow. I tried everything I could think of before asking here. Thanks in advance for any help!



  • @Wayne-Workman Ubuntu Server 14.04


  • Moderator

    @dustindizzle11

    What OS did you install 1.2.0 on? That version of FOG doesn’t play well with newer Linux distributions.



  • UPDATE: This was fixed. The problem was that the local fog user on the machine had no SHELL tied to it. Giving the fog user a shell fixed the FTP problems all around (I have no idea why fog had no shell in the first place). If another person runs into this, you can see if the fog user has a shell by viewing “/etc/passwd”. If the fog user has no shell you will see something like “fog:x:1002:1002::/home/fog:”. I simply edited the passwd file to “fog:x:1002:1002::/home/fog:/bin/bash”, which specified a shell and fixed the issue.


Log in to reply
 

508
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.