Imaging Lenovo m93z with Fog 1.2.0 - won't boot



  • I’ve googled the heck out of this and found some others that were having issues with the lenovo m93z desktop with fog in older versions, but nothing recent. I saw someone had success with a kernel here, but that was from 2 years ago and figured this would have been fixed by now in current version (maybe not?)

    My problem is I got everything the way I wanted on one of the machines and did a upload to the fog server (I used fog prep, no sysprep, it’s worked on everything else I’ve imaged). I downloaded it to one of the other m93z’s and it won’t boot… just blinks at post and can’t find the MBR or something. I’ve tried doing a clean install of Win 7 x64 and that’s great until it doesn’t recognize the built in UEFI product key for Windows 7 so I’m back to square one.

    I went into BIOS and tried switching from ACHI to EDI (nope, but did allow me to boot when I did the clean install) tried changing from UEFI to Auto and Legacy first (same thing). Tried pretty much ever possible combination. I even put my x64 Win 7 USB in to try and do a startup repair to get the MBR restored and it’ll sit working on it for 2 hours each time and then give up.

    Anyone else have any ideas I can try?

    I posted this in spiceworks as well.



  • Thanks for the help Sebastian. Yeah, I meant AHCI :)

    I followed what some others suggested on the spiceworks forums and upgrading to the Trunk version. I made sure to factory reset my bios settings so it was uniform with my source computer (where I didn’t mess with anything) and it booted up! Everything works great and the windows key applied all by itself like it should. I’m a happy :)

    Thanks!


  • Developer

    @mlerch A few things that come to my mind when reading your post. Changing BIOS settings like AHCI/IDE (I guess that is what you mean) and/or UEFI/Legacy/BIOS is not a simple thing. It changes the behaviour of that machine a lot. Especially in terms of PXE booting and imaging. Please make sure that you have all your machines configured exactly the same I’d suggest.

    That said I can say that FOG 1.2.0 won’t work with UEFI! As well you don’t need fogprep at all! This was used in earlier versions of FOG. It probably didn’t hurt but you don’t need it.

    Which image type did you upload? “Resizable” or “Single Disk - Multiple partitions”? I’d suggest going with the later first. Just make sure that the target disk is bigger or exactly the same size (to the sector) than the source disk.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.