FOG Client Failing after recent W10 update



  • After a recent batch of Windows 10 Updates, the FOG client will no longer rename the device or ad to AD. If I use an older version of the W10 image - it works flawlessly. This just manifested this past Wednesday.


  • Moderator

    @dmoseley What’s typically happening if the fog client is running, is that during the OOBE setup the fog client may do an unscheduled reboot which kind of whacks the OOBE setup. Starting the service at the end of the setupcomplete.cmd makes sure that windows is fully setup before the fog client connects the device to AD or renames the computer.



  • @george1421 thank you, @george1421. I will try that. Although, I haven’t been syspreping my fog images in the past and they’ve always worked fine. I used to use fogprep, but haven’t since Windows 7. I’ll give it a go.


  • Moderator

    @dmoseley On your pre-sysprep’d system after installing the FOG client you need to stop the service and disable its startup. Update your setupcomplete.cmd file to enable the fog service account. Then sysprep and deploy the system.

    Ref: https://wiki.fogproject.org/wiki/index.php?title=FOG_Client#FOG_Client_with_Sysprep (at the very bottom)



  • Matthew, I’m in the same situation, did you find a solution to error code 2725? I’m getting the same error. I know it has something to do with not being able to change the hostname, because if I manually change the hostname, but don’t bind to AD, and reboot, the fog service binds to AD just fine. Any input very much appreciated. Thanks.


  • Moderator

    @Matthew-Bostdorff If you have time to test this. See if removing the FOG client, reboot, do the in place upgrade, reinstall client resolves the issue. Also if you could sanitize and post that log file that jbob mentioned that will help trying to diagnose the issue. But the days of that old client are numbered. As soon as FOG 1.3.0 is stabilized, I’d recommend that you update so you can take advantage of the new client.



  • @Jbob @george142 I will continue to test this, but so far - yes, @george1421 you are correct in your assessment.

    @Jbob Not coarse at all - it’s a reality. Incidentally, re-installing the FOG client after the W10 version upgrade DOES NOT resolve the issue. So far the only thing that works is starting from scratch and letting W10 do it’s thing and THEN installing the FOG client.

    I hope I am doing something really dumb and I am the only person experiencing this. :)


  • Senior Developer

    @Matthew-Bostdorff
    If the legacy client is experiencing this issue then there is nothing we can do. The legacy client was written several years ago with XP in mind. Not to sound too coarse, but the legacy client is long past deprecated and quite frankly I’m surprise it has lasted this long. There is no ‘fix’ we can release because we are not at fault. Your best bet is to make a new image that has the update installed and also the legacy client. You could also use GPO to re-install the client on the machines. There is no patch we can roll out: it is not a firewall issue and its not that the dlls aren’t being loaded. We can’t guarantee that a several year old piece of software will work with the latest versions of windows. That is one of the reasons we created the new client.

    Now with that said, if you could upload the content of C:\Windows\Debug\NetSetup from a machine that has this issue it may help me narrow down exactly why this is occurring and see if the new client would suffer from the same issue.


  • Moderator

    @Matthew-Bostdorff Thanks for the clarification and the additional info.

    Just so I understand. If you had the RTM release in place and then fog client installed, then you did the in place upgrade to v1511 the FOG client stops responding to FOG tasks. But if you install RTM clean, install v1511 then install fog client everything works as expected.

    If that is the case it sounds like the in place upgrade is stepping all over the fog client (I won’t go into how I think MS made a mistake with these in place upgrades). One thing that comes to mind is that the firewall settings has been reset blocking communication or the dlls the fog client registers to are no longer valid after v1511 is installed. BTW, did I mention how this new MS process is going to bite.

    I wonder if @Jbob can give a little insight to what the 1.2.0 stable fog client hooks into when it installs. We need to drive a solution here because you are only the first one to come across this issue. More will follow.



  • @george1421 It appears the issue is only with v1511. And currently it appears that it only breaks if I upgrade the PC with the FOG client installed. Preliminary tests indicate that I can load Windows from scratch, do ALL updates, then load the FOG client - and it works!! However, if the FOG client was installed prior to the v1511 update, and then the PC goes through that upgrade process - it breaks the client.



  • @Tom-Elliott THIS IS NOT SOLVED! I am using the production version of 1.2 with the client that came with server 1.2. The client works great on ALL PC’s in my environment until you run a W10 version upgrade through Windows update, then it breaks the client.

    I did try to upgrade to the NEW client, which obviously did not work.

    I am now trying to load Windows 10 from scratch, do all the updates - and THEN install the FOG client.


  • Senior Developer

    I think you’re thinking in reverse.

    The problem he was having is he had the new client installed (for whatever reason) while running version 1.2.0. The new client doesn’t know anything about 1.2.0 so it wouldn’t have worked at all.


  • Moderator

    @Tom-Elliott The new client was under my suggestion.

    If I understand the OP he was running fog 1.2.0 stable with the client at that time. Something through windows update has now broken the older client. I asked what version of the client the OP was using because I knew the client was just updated, but not aware that it wasn’t backwards compatible to 1.2.0 stable. My mistake.


  • Senior Developer

    Sounds to me he was running 1.2.0 but trying the new Client on the systems. The new client will not work with 1.2.0.


  • Moderator

    Is this issue solved? I see the thread is marked solved, but I don’t see a clear solution for you.



  • @george1421 George, just saw this post from Tom Elliot:

    om Elliott  Senior Developer
    5 months ago  @el-psycho

    @el-psycho the new client can only be used with the development versions of fog. This is because the new client was coded along side the development versions. And believe me there are a lot of changes to make it work. The compatibility of legacy and new clients is still present, but 1.2.0 will NOT work with the new client.

    So downloading the new client is not a viable option based on this info.



  • @george1421 I have tried using the new client and it fails on install wanting some CA Certificate?? Then I thought I read that you can only use that client on the server that matches that client. If someone knows otherwise, let me know. Right now I am trying a fresh install of W10 and all updates PRIOR to client install to see if it works.


  • Moderator

    What version of the fog client are you using?

    And for clarity, are you having an issue with the first release of windows 10 or is it the new release from November (v1511)?

    I don’t have an answer for you on your problem, right now just trying to collect some additional details.

    I know that they just updated the fog client to 0.9.8 or 0.9.9 to address several issues.



  • @Tom-Elliott I am using FOG 1.2 and the values I am using in the AD settings are:

    Join Domain after task: "Check"
    Domain name: VBS
    OU: blank
    Domain username: “username only” no domain
    Password: “ecrypted with fogcrypt”

    Frankly, though, this information is irrelevant because as you can read from my first post - it is working on ALL clients (all 1100) PRIOR to the Windows 10 update. Any device that gets the update (I am speculating, but W10 just pushed out a version update) those devices now fail. So, I can literally image a machine with an image that was created prior to that update and it works fine, renames and joins the domain. If I image a client with an image that includes that Windows update, it no longer will rename or join the domain.

    I appreciate the help!


  • Senior Developer


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.