(SVN) Adding needed repository... Failed!



  • Is there anyway to just whitelist the fog server’s IP to have unfiltered access?



  • @george1421 We removed proxy but I had to set the previous one a bit everywhere.
    I have unset http_proxy, check bashrc.


  • Moderator

    Ok from what I understand your fog server is behind a proxy server, right?

    If that is the case you need to set (export) the environment variables to define your proxy server. Also you will need to update the settings in /etc/wgetrc (if you forget this you will not get the kernels and inits).

    As I see you are using svn then you probably have the proxy servers set in /etc/subversion/servers

    Here is what I have exported in /etc/bashrc

    export http_proxy=http://<proxy_server_ip>:<proxy_server_port>
    export https_proxy=http://<proxy_server_ip>:<proxy_server_port>
    export ftp_proxy=http://<proxy_server_ip>:<proxy_server_port>
    export no_proxy=<fog_server_ip>

    You didn’t happen to mention what OS you are using here for rhel based (rpm/yum) you need to update /etc/yum.conf with your proxy server setting too.


  • Moderator

    What happens when you do sudo add-apt-repository?

    If it says it’s not installed, then do the following:

    sudo apt-get install software-properties-common python-software-properties

    If it is installed, it’s most likely a proxy issue.


Log in to reply
 

446
Online

5.9k
Users

13.3k
Topics

125.0k
Posts