How to add new image into Advanced menu (like in fog_0.32)



  • Hi everyone,
    I would like to add into advanced menu a direct link to image i just created to make it available for quick imaging as I’ve had in fog_0.32 so I could select an image and immediately download into machine.

    kernel bzImage root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=192.168.2.1 web=192.168.2.12/fog/ consoleblank=0
    loglevel=4 type=down img=win7actsysprep ftp=192.168.2.1 imgType=mps osid=5 storage=192.168.2.12:/images capone=1 imgFormat=mps
    imgfetch init.xz && boot || goto MENU
    

    this is the code I added into advanced menu but it gives me an error (kernel panic)
    What I actually need to achieve it ?
    Or what is wrong with the lines I pasted ?

    Mod edited to use code box.


  • Moderator

    I created a post a few days ago about booting a MDT iso image via the ipxe boot menu. This may help you on your quest as long as you are using a svn trunk. The only thing I think I would change from this post is to move the place I stored the iso image out of the fog directory directly. In the instructions I said to place the files in /var/www/html/fog/iso , moving forward I would put them in /var/www/html/iso This location is still addressable by apache but won’t collide with anything in the fog distro.

    https://forums.fogproject.org/topic/6161/debian-8-fog-trunk-pxelinux-on-ms-server-and-ms-dhcp-help/15



  • I have old version of FOG installed and in there I have one link to an .ISO file directly. It is actually DELL diagnostic file, but boots fine in ISO. Now in this new version of FOG 1.2.0 I have no glue where to store my .ISO file and what file I need to modify and how, to make my .ISO file appears in the default(!) menu options to boot like before.
    Could you just simple help, I am quite new.
    Is there anything to do with “BootMenu.class.php”. How?


  • Senior Developer

    @Robx64 You need to update.

    cd /root/svn/trunk/
    svn up
    cd bin
    ./installfog.sh -y
    

    Of course the cd change to the location you downloaded.



  • @Tom-Elliott
    Version I just installed is:
    FOG Configuration
    FOG Version Information
    Version: 5475

    You are not running the most current version of FOG!
    You are currently running version: 5475

    Latest stable version is 1.2.0

    Latest git version is 5539


  • Senior Developer

    @Robx64 First update to the latest then you will need to edit the quick image menu item from the GUI.

    This is the original information

    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    

    Make it read as:

    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    


  • Finally i managed to install this cra…ntastic FOG version ;)
    Everything works so far, list of images is created but … there is a but, how can I turn off this stupid login page when i chose quick imaging ?
    I don’t want it/don’t need it :)


  • Developer

    Good to hear! I’ll mark this solved. Better you start a new thread if you run into other issues.



  • Thanx guys, I just upgraded to 14.04, installed svn and finally I got working FOG 5475
    Now I have to install it again on production server :)


  • Developer

    @Robx64 said:

    Depends: php5-common (= 5.6.15+dfsg-1+deb.sury.org~precise+1) but 5.3.10-1ubuntu3.21 is installed

    Maybe try uninstalling php5-common first: apt-get purge php5-common && apt-get update && apt-get install php5



  • @Quazz
    Not using it, just downloaded and tried to install but I’ve met a lot of problems,. Currently upgrading dist to 14.04


  • Moderator

    @Robx64 said:

    @Quazz said:

    I’m on git version 5475

    Yeah sure, where can i get it ?

    If you’re using svn:

    Navigate to the svn directory you set up earlier

    svn up -r 4408

    Then just install as usual.

    Svn and git versioning are different, hence the different number here.



  • @Quazz said:

    I’m on git version 5475

    Yeah sure, where can i get it ?


  • Moderator

    I’m on git version 5475 if you want to try a (from what I’ve seen) stable trunk release.



  • @Sebastian-Roth said:

    kernel bzImage initrd=init.xz root=/dev/ram0 …

    Still nothing, what can cause this problem ? Any ideas ?



  • @Sebastian-Roth
    Now I’m getting: Kernel -panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
    Any suggestion ?



  • As Tom said I tried to install SVN version and unfortunately it stops while installing php … :(
    Here are the settings FOG will use:
    Base Linux: Debian
    Detected Linux Distribution: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 192.168.2.4
    DHCP router Address: 192.168.2.1
    DHCP DNS Address:
    Interface: eth0
    Using FOG DHCP: 0
    Internationalization: 0
    Image Storage Location:
    MySQL Connection Type: MYSQLI_ASYNC
    Donate: 0

         DHCP will NOT be setup but you must setup your
         current DHCP server to use FOG for PXE services.
    
         On a Linux DHCP server you must set:
             next-server
    
         On a Windows DHCP server you must set:
             option 066 & 067
    
                   Option 066 is the IP of the FOG Server: (e.g. 192.168.2.4)
                   Option 067 is the undionly.kpxe file: (e.g. undionly.kpxe)
    

    Are you sure you wish to continue (Y/N) Y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Adding needed repository…OK

    • Preparing Package Manager…OK

    • Packages to be installed:

        apache2 php5 php5-json php5-gd php5-cli php5-curl mysql-server mysql-client tftpd-hpa tftp-hpa nfs-kernel-server vsftpd net-tools wget xinetd sysv-rc-conf tar gzip build-essential cpp gcc g++ m4 htmldoc lftp openssh-server php-gettext php5-mcrypt php5-mysqlnd curl libc6 libcurl3 zlib1g php5-fpm libapache2-mod-php5
      
    • Skipping package: apache2…(Already Installed)
    • Installing package: php5…Failed!
      I can’t go any further with installation.
      Tried upgrade system, fialed …
      root@odoo-test-server:/svn/bin# apt-get upgrade
      Reading package lists… Done
      Building dependency tree
      Reading state information… Done
      You might want to run ‘apt-get -f install’ to correct these.
      The following packages have unmet dependencies.
      libapache2-mod-php5 : Depends: apache2-api-20120211
      Depends: apache2 (>= 2.4)
      Depends: php5-common (= 5.6.15+dfsg-1+deb.sury.org~precise+1) but 5.3.10-1ubuntu3.21 is installed
      E: Unmet dependencies. Try using -f.
      Tried -f as well …


  • Hi Tom, Unfortunatel there is a lot of problems with SVN installation so I need temporary solution then I will work on it further.

    I’ll check what Sebastian said, I was actually quiet close to it :)
    to do it :)
    :)
    Thank guys


  • Senior Developer

    If you can upgrade to trunk what you are asking is already implemented into the quick image option. You select quick image, sign in with a GUI user and password, and it will present a list of all the images on the server. You can select any of those images and it will perform a download task using the selected image.


  • Developer

    @Robx64 try kernel bzImage initrd=init.xz root=/dev/ram0 ...



441
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.