Rsync error when Implementing Mutliple TFTP servers

  • Hello - I’m working on re-implementing the “location patch” with Multiple TFTP servers for different lan segments.

    When I get to this command on one of my remote nodes:

    [CODE]$ rsync -rv /tftpboot

    receiving file list … done
    rsync: stat “/tftpboot/pxelinux.cfg” failed: Stale NFS file handle (116)

    sent 39350 bytes received 26796 bytes 132292.00 bytes/sec
    total size is 18179419 speedup is 274.84
    rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1526) [generator=3.0.7]

    I’ve done some searching for “Stale NFS file handle (116)” but not getting any clear answer to the issue.

    Remote site: Ubuntu 10.10, Fog 0.31 on bare metal
    Master: Ubuntu 8.04.3 LTS on ESXi

    Where to start troubleshooting this one?

    Thanks, Pat

  • Developer

    Hi PatinMT,

    FOGServer does but if you set it up as a Node it will not unless you modify the installer for node installation. Might be worth doing so if you have future setups?

    Well done in solving your own issue 🙂 and posting the solution.

  • As a tech support professional my self, I love it when people write back to say that they’ve solved their own problem:

    apt-get install tftpd-hpa

    I was wrong to assume that fog (0.31) was installing tftpd for me.

    We now have fog joy once again!

  • Just an added note…

    I do have a symlink set up for var/lib/tftpboot -> /tftpboot


  • Thanks Lee, that solved it, the next time I ran the rsync it worked.

    Now this thread may take a turn, and not fit the category, but here goes.

    This remote site: Ubuntu 10.10 on bare metal…seems to refuse to run tftpd. I’ve looked at various other threads and sites, and have concluded that:
    ps ax | grep tftpd
    should show me that the tftpd process is running (or perhaps in.tftpd) at any case I do not see it.
    Further a command of:
    tftp RemoteServerIP get pxelinux.0
    From even a windows client, should cause a file transfer to initiate, but all I get is “Connect Request Failed”

    From my understanding it is the fog install that installs / starts tftpd service, so I re-ran the setup. With the rsync command and tftpboot/pxelinux.0, re-running install throws error about that being in a read only state…so I umount, then re-run ./, but still no joy, I cannot connect to the tftp service, nor see a tftpd process running on my remote site.

    What did I miss here?

    Thanks, Pat

  • Developer

    try to unmount and remount the pxelinux.cfg share

    umount /tftpboot/pxelinux.cfg
    mount /tftpboot/pxelinux.cfg