Still problems deleting a task



  • The problem deleting a task has changed a bit. Now I get a white page in the browser and this error in apache log:
    PHP Fatal error: Uncaught exception ‘ReflectionException’ with message ‘Class does not exist’ in /var/www/html/fog/lib/fog/FOGBase.class.php:63\nStack trace:\n#0 /var/www/html/fog/lib/fog/FOGBase.class.php(63): ReflectionClass->__construct(’’)\n#1 /var/www/html/fog/lib/fog/FOGPage.class.php(417): FOGBase->getClass(NULL)\n#2 [internal function]: FOGPage->deletemulti()\n#3 /var/www/html/fog/lib/fog/FOGPageManager.class.php(67): call_user_func(Array)\n#4 /var/www/html/fog/management/index.php(24): FOGPageManager->render()\n#5 {main}\n thrown in /var/www/html/fog/lib/fog/FOGBase.class.php on line 63, referer: http://192.168.68.254/fog/management/?node=task

    Running svn 5469 on Centos 6.7


  • Senior Developer

    I think I finally understand what the issue is.

    You are not allowed to delete tasks from the Search list. This was never the intent, but it was mistakenly put in.

    I’ve now fixed it. For now, I’m not going to allow any deleting/canceling from the search fields. I also am ensuring you can cancel all tasks that are in a progress state (meaning they’re not complete or cancelled already).



  • @pmonstad Hm, only an active task was possible to delete after search/filter. My two queued tasks are not possible to delete.



  • It is possible to delete tasks when I search/filter first.



  • You marked my previous post as SOLVED, so I made a new one. This time I got another error than last time, so I concluded this was another bug. I’m so sorry.


  • Senior Developer

    If you’re seeing the same problem as on the other thread, why create another new thread?


Log in to reply
 

402
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.