Tot possible to register client from boot menu



  • I’m running FOG svn (from 17.11.15) on a fresh CentOS 6.7 server. I have managed to upload an image, but not to deploy. All clients have worked previously on an older FOG installation.

    When I try to deploy the client loops telling “Sendig discover”. The external DHCP server has not been changed since this worked previous.

    I then tried to solve this by deleting the host from FOG. When pxe menu shows again it says host is not registered, but there is no menu item letting me to register it again. All register options are allowed in FOG settings.

    I now have two problems: Deploy don’t work and not possible to register a host.


  • Senior Developer

    Are you still not able to register clients?


  • Senior Developer

    @pmonstad No, it is on by default. There was a rev a few back where I had a missing bracket in the code and it basically wasn’t passing the information properly for the checked boxes.

    A fresh install will have the registration enabled, but it’s more likely an update to the FOG Settings elements caused the deselection of not just that (FOG_REGISTRATION_ENABLED) option is now deselected as well.



  • @ch3i So to sum this up: There is a known problem in FOG concerning this and the message “Sending discover” will exist until a fix is found and implemented?


  • Moderator

    @pmonstad Because I’ve the same error on computers with two network cards connected to two Vlans



  • @ch3i What do you mean? I have a LAN and a WAN card in the client. It it a Thinkpad T400 and I use LAN when working with FOG: I have not disabled the WAN card and I have never done so before.

    I have tested several other of my clients. Some works and some fails with this “Sending discover” message.


  • Moderator

    @pmonstad Have you two network cards connected ?



  • ![0_1447837559241_IMAG0709.jpg]
    Thanks! The option is new to me. The tip says is on on by default. It is not. Anyway, the client still reports “Sending discover” when I try to register it with the FOG server.


  • Moderator

    @Sebastian-Roth said:

    Didn’t know that there is a new option called FOG_REGISTRATION_ENABLED in FOG Settings… Check the settings in your web interface…


Log in to reply
 

712
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.