Bugs in latest FOG Trunk 5360



  • Hi there,

    Just wanted to report some issues with the latest FOG trunk.
    I’m currently running FOG trunk 3594 on CentOS 6.7 with 1 Storage Node.
    I have created a replica CentOS 6.7 server with replica DB and FOG instance to allow me to test with.
    All my testing is done in Chrome as it appears to be the browser where FOG WebUI is most compatible.

    Installation:
    On install of latest trunk and when the installer is attempting to ‘Backing up the database’, it fails and the install stops.

    • Setting up SSL FOG Server…OK
    • Restarting Apache2 for fog vhost…OK
    • Changing permissions on apache log files…OK
    • Backing up database…Failed!

    The way I get around this is by editing the installfog.sh file and removing all association to Backing up the database.


    Services:
    Also, I notice that FOG services are doubling up. This doesn’t seem normal?
    On latest FOG Trunk…
    [root@fogtest trunkfog]# ps -ef |grep fog
    root 7162 1 0 16:11 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    root 7185 1 0 16:11 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGSnapinReplicator/FOGSnapinReplicator
    root 7197 1 0 16:11 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGTaskScheduler/FOGTaskScheduler
    root 7210 1 0 16:11 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGPingHosts/FOGPingHosts
    root 7215 7162 0 16:11 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    root 7227 7185 0 16:11 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGSnapinReplicator/FOGSnapinReplicator
    root 7237 7197 0 16:11 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGTaskScheduler/FOGTaskScheduler
    root 7254 7210 0 16:11 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGPingHosts/FOGPingHosts
    root 7603 1 0 16:14 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGImageReplicator/FOGImageReplicator
    root 7606 7603 0 16:14 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGImageReplicator/FOGImageReplicator
    root 7617 2547 0 16:14 pts/0 00:00:00 grep fog

    On FOG Trunk 3594…
    root 2789 1 96 Nov15 ? 1-13:45:27 /usr/bin/php -q /opt/fog/service/FOGPingHosts/FOGPingHosts
    root 4416 1 0 Nov15 pts/0 00:00:20 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    root 4452 1 0 Nov15 pts/0 00:13:40 /usr/bin/php -q /opt/fog/service/FOGImageReplicator/FOGImageReplicator
    root 4499 1 0 Nov15 pts/0 00:05:23 /usr/bin/php -q /opt/fog/service/FOGTaskScheduler/FOGTaskScheduler
    root 4549 1 0 Nov15 pts/0 00:00:00 /usr/bin/php -q /opt/fog/service/FOGSnapinReplicator/FOGSnapinReplicator
    root 32183 3075 0 18:21 pts/0 00:00:00 grep fog


    Image Management:
    In Image Management, when I attempt to Delete a Storage Group from an Image, it does not remove the Storage Group from the list, even though it displays ‘Image updated’ at the top. No problems with adding Storage Groups to an Image, just can’t delete the Storage Group associations.


    Browser:
    When I go to the Log Viewer, the browser displays a ‘HTTP 500 Internal Server Error’.
    When I select Login History, the browser displays a ‘HTTP 500 Internal Server Error’.
    In Windows 7 IE 11, the icons across the top display as bullet points with no icons. Dashboard doesn’t display properly (no graphics or graphs - see screenshot below). In Win10 Edge browser is fine.
    0_1447660728269_Untitled.png

    Location Management:
    After clicking Add when Creating a New Location in Location Management, the checkbox for TFTP From Node: becomes 47 and 53 underneath it if the box was not checked, and 55, 53 if checked. Checkbox no longer available against TFTP From Node.

    Doesn’t seem like you can delete host/s from a location either even though it displays ‘… saved successfully’ above. Adding nodes to a location appears to be fine.


    Plugin Management:
    When I attempt to install the LDAP plugin from Activate Plugins, it disappears in to Install Plugins fine, but when I click on the LDAP plugin there and select Install Plugin, the page appears to refresh to the Installed Plugins section with the Install Plugin button and description of the plugin I was trying to install. So the LDAP plugin fails to be installed and remains in Install Plugins.

    Other plugins such as pushbullet, wolbroadcast plugins install without issue.


    I haven’t tried imaging or replicating to a storage node. I know I’ve tried a number of recent trunk versions and storage node replication is broken.

    Let me know if you require any further information.

    Cheers
    David



  • Hi @Tom-Elliott
    Yup all good to close this one as resolved.
    Thanks for your awesome work!


  • Senior Developer

    I’ve marked this as solved and I hope it is. Please let me know if there’s still any issues. At least this one got a bunch of bugs involved and corrected.



  • @Tom-Elliott
    ok cool… thanks again Tom… will do.
    FOG Settings page is all good. Plugins also. :+1:


  • Senior Developer

    @Toby777 Fixed this issue, I had a missing bracket in the line. I’d recommend, as you updated settings, using one of the db backups from /home/fogDBbackups please revert so your old settings are back in place. Then this should be fixed for you as well.



  • Actually sorry, I lie… It looks like the Plugins icon has disappeared from the row of icons. I look in FOG Settings and it isn’t enabled. When I tick the box to enable Plugins and click Save, it doesn’t get enabled and the checbox is still clear, even though it says ‘Settings successfully stored’.

    My previously activated Location plugin is still loaded and appears as an icon.

    EDIT: Looks like it applies to all the checkboxes in the FOG Settings page.

    I noticed a few were no longer checked , even though they were previously. When I try to check the boxes and click Save, the setting appears to not be saved even though it says it is saved.



  • @Tom-Elliott
    Hi Tom…
    Have confirmed that all those items I mentioned have been resolved. (except for the IE view issue but that’s no big deal ;)) Thanks again!
    I will try updating my production fog server to the latest trunk and test out image replication to the SN and imaging hosts and let you know how it all goes.


  • Senior Developer

    @Toby777 I think issues of replication were brought on by the way replication occurs now, compared to before.

    Replication in 1.2.0 and earlier was only done Master Node to Other nodes in the same group. Images could only be assigned to one group.

    For trunk, you can now assign images to multiple groups which will allow the image to replicate across groups as well as master->node replication.

    It uses totally different methods for replicating and managing groups which was likely the reason you were seeing problems to begin with.



  • Thanks for that @george1421.

    I have added those entries though it kinda looks like Tom may have removed the Backing up of the database from the installer?

    My FOG server has been a working fog server for about a year or so without any problem. It was originally set up on 0.32, then saw an upgrade to 1.2.0, then to a trunk version (32??). Unfortunately, I can’t remember what trunk version it was running at the time prior to upgrading it recently.

    The only reason I thought to upgrade it was when I had installed a Storage Node (in another city) last week. The SN was running 1.2.0 and at the time, the images were being replicated to the SN without issue. When I then upgraded the SN to the latest trunk at that time, it seemed to have broken replication because any updated images would no longer transfer through to the SN. It even wasn’t showing up on the logs.


  • Moderator

    @Toby777

    There are a few things that you might do to clear this up (proxy server related). I run FOG on centos 6.7 behind a proxy server and this is what I needed to do.

    In the bashrc file I placed the following commands.

    export http_proxy=http://192.168.1.10:3128
    export https_proxy=http://192.168.1.10:3128
    export ftp_proxy=http://192.168.1.10:3128
    export no_proxy=“192.168.1.88”

    In your wgetrc you can have the proxy settings too. The key is the no_proxy variable. That needs to be set to the IP address of the FOG server. Once these are set log out and back in. These new env variables will be set. From there FOG will install and backup correctly. If you look at the code for the backup, the script uses wget to pull the backup image. Well, wget isn’t that smart. Its trying to contact the proxy server instead of just connecting locally. The no_proxy statement tells wget to not proxy any requests for the FOG server.

    As for the second question, that to find out if this was a new install that never worked, or a working install that broke after the upgrade.



  • @Sebastian-Roth
    Thanks for that. I will run though that wiki.


  • Developer



  • Hi @george1421,

    1. Yes this FOG server is behind a proxy. I actually added http_proxy & https_proxy settings in /etc/wgetrc thinking it would resolve it but I guess not?
    2. I’m guessing you mean, has the FOG server worked prior? Yes. I did upgrade it from 1.2.0 to trunk 3590. So was now looking to upgrade it to the latest version. Apologies if you meant something else.

    Hi Tom,
    Thanks for the quick response.

    Thanks for clarifying about the multiple spawned services.

    Apologies I should have known better and to have checked the Apache error log. This is the error log from apache…

    [Tue Nov 17 21:09:59 2015] [error] [client 192.168.23.35] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘FOGFTP: Login failed. Host: 192.168.23.176, Username: fog, Password: ******, Error: ftp_login(): Login incorrect.’ in /var/www/html/fog/lib/fog/FOGFTP.class.php:29\nStack trace:\n#0 /var/www/html/fog/lib/pages/FOGConfigurationPage.class.php(625): FOGFTP->connect()\n#1 [internal function]: FOGConfigurationPage->log()\n#2 /var/www/html/fog/lib/fog/FOGPageManager.class.php(67): call_user_func(Array)\n#3 /var/www/html/fog/management/index.php(24): FOGPageManager->render()\n#4 {main}\n thrown in /var/www/html/fog/lib/fog/FOGFTP.class.php on line 29, referer: http://192.168.23.176/fog/management/index.php?node=about

    Note: I masqueraded the password with ******

    So I’m guessing from the error above, it is because the FTP credentials are incorrect on the test server that I created?

    Thanks for resolving the reported bugs so quickly and again, my apologies for not performing my own self checks with the http errors I was getting. Not quite sure why the display is like that in my Win7 IE11. I’ve even launched IE with no-addons and the page is still displayed same. It’s no big deal really because it is fine with Chrome & Firefox. I just thought I would mention it just in case.

    I’ll update to the latest trunk now and give it another go. Thanks again!


  • Senior Developer

    Services are doubling up because there’s a master item that actually does the job. There are two processes of the FOG services, specifically, because they’re spawned with a parent->child type system. The service library checks every so often the status of the FOG Services, and if they’re in a “strange” state, will respawn the process to try to keep things running smoothly. Double processes are expected because of this.

    Image storage group associations are now fixed, thanks for reporting. I will push shortly.

    Pertaining to DB Backups, are you running behind a proxy? Do you have a specialized setup for vhost information?

    I’m not seeing any issues with HTTP 500 for log viewer, perhaps you can provide apache error logs?

    Login History from Reports Looks fine, maybe provide apache error logs?
    Login History from Host page looks fine, maybe provide apache error logs?

    I’m not seeing any issues as you stated with Edge, Chrome, Firefox, Internet Explorer, Safari, or Opera.

    Location management, fixed the issue with the numbers displaying instead of the actual field. Thanks for reporting and I will push shortly.

    LDAP Install has been fixed and will be pushed shortly, thanks for reporting.

    And push is being made as we speak.


  • Moderator

    I guess I have two questions here

    1. Is this FOG server behind a proxy server or does it have direct internet access. I have seen if FOG is behind a proxy server wget gets confused when it tries to backup the database. There is a fix for this.
    2. Has this ever worked? Or did the system work then you upgraded to the latest svn trunk and it broke? Knowing this will help to know if this was a botched install or something went sideways with the upgrade.

Log in to reply
 

432
Online

38940
Users

10697
Topics

101497
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.