SVN 4334 Cloud 5315 Cannot install or use location plugin



  • Freshly installing Ubuntu 12.04.5 (also tried 14.04.3), installing all from apt-get upgrade (also tried with/without doing apt-get dist-upgrade), and pulling down fog_trunk, running a default normal installation…

    Enable plugins: Ok
    Activate Plugins, selecting location: Ok
    Install Plugins, selecting location: It ends up going to a white screen with just the plugin information on both Chrome and Firefox (see likely unhelpful screenshot at bottom), and never actually installs.

    Within /var/log/apache2/error.log I see the following:

    PHP Fatal error: Call to a member function getRunInclude() on null in /var/www/fog/lib/pages/PluginManagementPage.class.php on line 91, referer: http://IPADDRESS/fog/management/index.php?node=plugin&sub=install

    PHP Fatal error: Call to a member function getRunInclude() on null in /var/www/fog/lib/pages/PluginManagementPage.class.php on line 91, referer: http://IPADDRESS/fog/management/index.php?node=plugin&sub=install&run=d5189de027922f81005951e6efe0efd5&plug_name=location&install=d5189de027922f81005951e6efe0efd5&plug_name=location

    Where’d I go wrong? This is about as close to a fresh, clean install as I’m going to get to try to rule things out.

    0_1447364906720_Capture.PNG



  • May or may not be relevant, we noticed as of a few revisions ago that imaging things based on location would try to pull the image from the wrong location. Uninstalling the plugin sort of worked, but left behind the Location column in the hosts view which listed them all as a location variable. Trying to re-install it gave similar results as trying to install it on a fresh install. (failed oddly)

    I can’t be more specific on what SVN this started with, sorry. We jumped up 2-300 on the Cloud counter last week, and I’ve pulled down SVN more than once in the last few days as commits have been made (i watch the activity log like a hawk). I apologize for my lack of concrete data to report here.


Log in to reply
 

722
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.