SOLVED Cannot boot into fog menu in UEFI mode

  • @Charlee593 said:


    verified working on 2015-06-24 using undionly.kpxe

    Are you purposely trying to UEFI boot? Have you not tried to put the laptops into legacy mode, or turn legacy option ROM support on?

  • @Wayne-Workman

    • Lenovo ThinkPad T430s and Dell Latitude E6540
    • I’m using the Ethernet port from the laptop

    I have more available laptops to test on, which one do you have that is working?

  • @Charlee593 What is the make/model of the device? Are you using a USB ethernet adapter?

  • @Tom-Elliott
    Thanks for fixing the fog menu. Now it loads to the fog menu. But it has trouble registering the device. After selecting the “Quick Registration” option on the fog menu, it stuck on ‘/init.xz’, like the image below.

    • Running on: Fog Project version 5283 (pull from github)
    • Kept the option 67 to ‘ipxe.efi’ (Also tried snponly.efi and snponly.efi, same result)


  • Moderator

    @Sebastian-Roth I agree, it seems a bit confusing to have two different version numbers. Hopefully there is a way to resync the numbers.

  • Senior Developer

    @george1421 There are two different version numbers. One is if you check out via SVN (currently 4305, see here: and the other one is GIT (5257 at the moment, the number you see in the cloud!). The source is in sync but version numbers aren’t as sourceforge was offline for a while a few months back.
    @Tom-Elliott Should we work towards abandoning sourceforge SVN all together? It can be pretty confusing to people being new to FOG.

    @Charlee593 We have been playing with the boot script embedded into the iPXE binary lately. Good to see that others are testing this as well. Seams like we haven’t got it all perfect yet. Even inputting the TFTP server won’t work in your case because iPXE does not try to get an IP via DHCP. Please give us a day or two. Thanks for reporting.


    • First: From what I can read between the lines and what I found out playing with this lately. I am pretty sure using the ‘ifopen’ check is not doing a good job anymore (newer iPXE source). I’ve tried this in different machines (BIOS, UEFI, VM) and it always returns OK even when IP information is not available from the earlier PXE ROM (like on my UEFI machine and probably Charlee’s too!). So this check is pretty useless from my point of view. A better check might be isset ${net0/ip} && ifopen || dhcp ... I guess but haven’t tried it out yet.
    • Second: As I see BIOS and EFI script is now the same - which is a good idea I think. But how do we remember to always make and test changes in both?? Better to only have one and reference it from both?
    • Third: Typo at the end ofline three: gotosetserv should be goto setserv I reckon.
    • Fourth: I am pretty sure I forgot something…
  • Moderator

    On the fog console page there is a cloud, what are the numbers on the lower right?

    The reason why I ask is that svn 4304 is somewhat old (in svn terms). I think the current SVN is in the 523x range. IF you are running 4304 there have been many great improvements since the svn you installed.

  • @Tom-Elliott Thanks for the super fast reply. I re-setup the fog server earlier today with the one in svn (Revision 4304), I believe it is fog 1.2.0.

  • Senior Developer

    I was made aware of this issue earlier but I do not know what is causing it.

    What version (specifically) of FOG are you using?

    I can try to revert the iPXE scripts a bit that handle the embedded functionality of the efi files, but there’s a separate underlying issue at play here.