Fog wont image RMA HD's



  • Good morning everyone, Hoping someone can help point me in the right direction for an issue we are having.

    We have several Lenovo M73 desktops. Out of the box with factory western digital hard drives, fog works fine

    Now that we are getting some seagates in from RMA’s, fog does not work to image. (A spare western digital we borrowed from a dell also does not image). We are able to queue the image process, it appears it’s booting into the image process including erasing MBR, then briefly displays ‘task completed’, restarts, and comes up with Missing Operating System

    On one of the RMA drives I did install ubuntu via usb successfully. Following that, I tried to imagine it with fog and it did just enough to erase MBR and then come up ‘missing os’.

    I also did a basic task --> mem test successfully, but that doesn’t have anything to do with the hard drive


  • Developer

    To me this means that even the MBR was not dumped to the disk. Otherwise you should at least see some kind of partitioning on the client that tried to download an image.

    Anyhow. Marking this solved as we probably won’t bother about going into the details any further. Thanks a lot for letting us know.



  • Thank you for the suggestion. The rma drives are a little larger, but running the diagnostics got me to see there was no partition on the drive. got me thinking that creating a partition might be necessary - and it was. I ended up using mini tool partition bootable to put a partition on, and now fog 1.2.0 works on these


  • Developer

    I am pretty sure this is because the RMA HDs are smaller than the disk you uploaded the image from. Disks are not always exactly the same size even if both models are labeled as e.g. 120GB!

    Bootup one of the clients you pushed an image to (or at least the MBR) in FOG debug mode (Host Settings -> Basic Tasks -> debug) and run the following command: fogpartinfo --list-parts /dev/sda. I am pretty sure it’ll tell you something like “cannot have partitions outside the disk”.


Log in to reply
 

426
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.