• hello again.
    so im having a problem now that when i try to take an image from a machine, i schedule a task for it,
    it runs but it says it cant mount /images/ to /DATA
    i mounted that manually… so im looking for the config.php file to change the location there to /DATA
    i looked at /var/www/html/fog/commons/config.php where it should be on centos 6.7
    but its not there … did they move it on fog 1.2.0 ?
    i just cant find it >< …
    trying to work with those instructions : https://wiki.fogproject.org/wiki/index.php/Change_NFS_location

  • Moderator

    Ok that tells me you only have /Data exported from your FOG server, I understand why the client can’t connect to the /images folder.

    For full disclosure this is what I get when I run the following commands.

    showmount -e localhost

    Export list for localhost:
    /images/dev *
    /images     *

    cat /etc/exports

    /images *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)

    I’m going to recommend that you add the above two lines to your /etc/exports file.

    Then run:

    exportfs -r

    Then run the showmount -e localhost command. This should then show you the exported /images directory.

  • [root@FOG etc]# showmount -e localhost
    Export list for localhost:
    /Data *
    [root@FOG etc]# cat /etc/exports
    /Data *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1,)

    Mod edited to use code boxes.

  • Moderator

    On my centos 6.7 there is a file of that name in /opt/fog/service/etc/config.php but that only points to the web root folder.

    I suspect that the setting you are looking for has moved to a different location.

    But to address your nfs issue. What does this command show you?

    showmount -e localhost

    And if you run this command do you see the nfs exports?

     cat /etc/exports