Imaging fails on one machine but worked previously.



  • Dear all,

    I wanted to put up this problem, and it’s solution, as it had me banging my head for ages, tom kindly connected up, and also spent ages trying to debug it.

    The problem was one of my machines just stopped downloading images. Obviously you assume it’s the machine, checked the bios for changes, compared it to a working machine, not the bios.
    Re imported the machine, no change. In the end I rebuilt the fog server totally, even gparted that partitions to make sure there was nothing left. Still no joy.

    Tom suspected it was the disks, had I put then in a raid array? No the disks were each attached to a sata controller, no raid. As Tom put it, “it’s the disks”.

    By now I’m getting concerned, as courses are scheduled and I can’t restore the correct images, not a career move.

    I decided to check the disks were working by installing 2008R2. I started the install, it saw the disks, but when it started copying files it initially paused for ages, as if it couldn’t access the disks. But it did, a delay of 3-4 minutes, create the partition.

    I then tried downloading an image from fog and it worked perfectly, and has been doing so since I installed 2008 that was subsequently over written.

    So what caused it? I re initialised the partition table before all this, and I wonder if somehow there was some form of corruption in it.

    I hope this helps someone, and many thanks to Tom for his help and “it’s the disks” comment

    Could someone mark it as solved please

    Julian


  • Moderator

    I would also say its the physical disk based on what you have posted. I have experienced a bad sector on a hard drive cause ghost and clonezilla to fail. I have not yet experienced this with FOG (just because with the other I’ve deployed units in the 1000s).

    I would ask 2 questions here.

    1. What is the hardware you are deploying to (ie Lenovo M93, Optiplex 9010, etc)
    2. Have you physically replaced the hard drive in this system. (I noted that you mentioned hard drives . Do you have more than one in this system?

Log in to reply
 

390
Online

38937
Users

10696
Topics

101490
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.