Fog server 4956 won't deploy image to host



  • I recently installed a fog Version 4956 on Fedora 22 64bit server. Everything went as planned with installation and first image upload. However when i attempt to download that image to a new host nothing happens. I setup the task for download then reboot the host to network and for some reason it just brings me to the FOG splash screen with options to register host etc… etc… Once I shutdown the destination host and check on the FOG tasks I see that the download task dispersal. as if it actually deployed the image. I get no warnings or error. I have tried using a new similar image i uploaded with the same results. deployingImage.PNG



  • Please ensure that if you are not using resizable image types, that the source HDD for the image is smaller or exactly identical to the destination HDD.

    You cannot change the image type and it simply take effect. After changing the image type, you must re-upload.

    If this does not work, use DBAN or other boot and nuke programs to quickly “zero” the source HDD, and then recreate the image and re-upload.



  • @Jordonlovik has reported that his issue still is not solved, and he is experiencing the same problem still.

    I think that it’s the same problem as here. https://forums.fogproject.org/topic/5956/images-not-being-deployed



  • Ok i think i fixed the issue. One of my images was way way to big (probably bad) and the other had the wrong storage configuration attached. once i changed to single disk multiple partitions the lighter image worked. Yippie!



  • everything completed successfully. the only thing that didn’t say Done! or Complete was. Backing up and replacing BCD… BCD not present. Also the host didn’t restart at the end like it said it would.



  • It sounds like a bug…

    Can you do a “debug deploy” task?

    At the CLI when it comes up, issue the fog command. Just hit enter for each step, and make note of where it goes wrong, and provide a screenshot as well.


 

628
Online

5.4k
Users

12.6k
Topics

118.7k
Posts