PXE Netboot Ubuntu 14.04 LTS Help



  • Hello,

    I have been attempting to boot Ubuntu 14.04 from fog’s PXE server but have been having some difficulties.

    :UBUNTU
    kernel http://${fog-ip}/fog/service/ipxe/ubuntu/vmlinuz.efi
    initrd http://${fog-ip}/fog/service/ipxe/ubuntu/initrd.lz
    imgargs vmlinuz.efi boot=casper root=/dev/nfs netboot=nfs nfsroot=${fog-ip}:/var/www/fog/service/ipxe/ubuntu fetch=http://${fog-ip}/fog/service/ipxe/ubuntu/filesystem.squashfs ip=:::::eth0:dhcp
    boot || echo failed to boot
    prompt
    goto MENU  
    

    The closest I get, is this. I’m not sure what I can do but maybe someone can point me in the right direction. Perhaps it is my /etc/exports/ ?
    Screenshot from 2015-10-16 11-55-49.png



  • @Asthea I have it working right now. Thank you everyone for the assistance. I have no idea if the fetch command is even needed. I will test with it out and continue to clean it up. But I am grateful that it is working. Hi-5 all around.

    :UBUNTU
    kernel http://${fog-ip}/fog/service/ipxe/ubuntu/casper/vmlinuz.efi
    initrd http://${fog-ip}/fog/service/ipxe/ubuntu/casper/initrd.lz
    imgargs vmlinuz.efi boot=casper vga=normal root=/dev/nfs netboot=nfs nfsroot=${fog-ip}:/var/www/fog/service/ipxe/ubuntu/ fetch=http://${fog-ip}/service/ipxe/ubuntu/casper/filesystem.squashfs initrd=initrd.lz locale=en_US.UTF-8 keyboard-configuration/layoutcode=us mirror/country=US
    boot || echo failed to boot
    prompt
    goto MENU  
    


  • Don’t forget to exportfs -a, I know I’m being captain obvious here, but I just want to make sure jbonilla doesn’t skip any steps.

    Just for comparison, this is how I boot:

    :ubuntu 
    kernel http://${fog-ip}/fog/iso/ubuntu64/desktop/casper/vmlinuz.efi
    initrd http://${fog-ip}/fog/iso/ubuntu64/desktop/casper/initrd.lz
    imgargs vmlinuz.efi root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/var/www/fog/iso/ubuntu64/desktop/ locale=en_US.UTF-8 keyboard-configuration/layoutcode=us mirror/country=US
    boot || goto MENU
    

    with chmod set to 755 on the folders. Btw, your vmlinuz and initrd should usually be located in the casper folder.



  • Your PXE Boot Menu Configuration…I added one and named it Ubuntu14

    kernel http://10.72.3.50/fog/service/ipxe/Ubuntu14/casper/vmlinuz
    initrd http://10.72.3.50/fog/service/ipxe/Ubuntu14/casper/initrd.lz
    imgargs vmlinuz root=/dev/nfs boot=casper netboot=nfs nfsroot=10.72.3.50:/var/www/html/fog/service/ipxe/Ubuntu14
    boot

    /etc/fstab should have an entry like this…I mounted mine here at startup.

    /home/bcs/Desktop/ISO/ubuntu-14.04.2-desktop-i386.iso /var/www/html/fog/service/ipxe/Ubuntu14 iso9660 loop 0 0

    Exports should have an entry like…or wherever your mount point is.

    /var/www/html/fog/service/ipxe/Ubuntu14 *(ro,async)

    This entry in exports will need to be recreated after any svn updates, since the installer overwrites the exports file.



  • @Uncle-Frank Hey everyone, I exported the ubuntu folder. I was able to mount it from another computer so I know it works. I will try moving it to /images since its already being exported when I get back Monday. Will update my results.


  • Developer

    @Quazz said:

    Did you add the Ubuntu folder to the exports file as nfs location?

    Thanks for pointing this out! Is /var/www/fog/service/ipxe/ubuntu exported via NFS? Maybe it’s easier to move that stuff to /images which is exportet via NFS by FOG anyway.


  • Moderator

    Did you add the Ubuntu folder to the exports file as nfs location?



  • @Uncle-Frank I tried that too. No luck still. I will try this again on Monday when I get back to work. Until then I will continue to research.


  • Senior Developer

    @jbonilla lose the path and only add the filename. Do not tell it where to grab the file as it is in memory.



  • @Uncle-Frank

    This is what I have now and I get the same result.

    :UBUNTU
    kernel http://${fog-ip}/fog/service/ipxe/ubuntu/vmlinuz.efi
    initrd http://${fog-ip}/fog/service/ipxe/ubuntu/initrd.lz
    imgargs vmlinuz.efi boot=casper root=/dev/nfs netboot=nfs nfsroot=${fog-ip}:/var/www/fog/service/ipxe/ubuntu initrd=/${fog-ip}/fog/service/ipxe/ubuntu/initrd.lz
    boot || echo failed to boot
    prompt
    goto MENU  
    

  • Developer

    @jbonilla Please re-read Tom’s suggestion on adding ‘initrd=initrd.lz’ parameter. From what I found on the net about this I am pretty sure he is right about this!



  • @Tom-Elliott When I have vmlinuz.efi out it doesn’t boot at all. I grabbed vmlinuz.efi straight from the disk. I’m still stuck here. If anyone has has luck with PXE booting Ubuntu id appreciate the help.


  • Senior Developer

    Perhaps it’s how you’re booting ipxe? You look like you’re telling the system to load from vmlinux.efi, but are you using an EFI ipxe file?

    That all aside, the other thing to look at would be

    imgargs vmlinuz.efi boot=casper root=/dev/nfs netboot=nfs nfsroot=${fog-ip}:/var/www/fog/service/ipxe/ubuntu fetch=http://${fog-ip}/fog/service/ipxe/ubuntu/filesystem.squashfs ip=:::::eth0:dhcp
    

    It should have the initrd=initrd.lz parameter such as:

    imgargs vmlinuz.efi initrd=initrd.lz boot=casper root=/dev/nfs netboot=nfs nfsroot=${fog-ip}:/var/www/fog/service/ipxe/ubuntu fetch=http://${fog-ip}/fog/service/ipxe/ubuntu/filesystem.squashfs ip=:::::eth0:dhcp
    



Log in to reply
 

354
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.