FOG Snapin Task Queued



  • First time poster and user of this great product. I tried searching on the forums and on Google, but none of the threads could help me.

    I’m running the latest version of Unbuntu and running FOG 1.2.0. I created a simple snapin for Google Chrome installation. For the “Snapin Run With” field i’m using “C:\Windows\system32\msiexec.exe”. For the “Snapin Run with Argument” field i’m using “/i”. I’ve uploaded my .msi file I downloaded for Chrome. For the “Snapin Arguements” field i’m using “/quiet” and i’m not checking the option to reboot. It creates the Snapin fine. I can go to the host and put it in the snap in group. Then I navigate back to the host, go to “Basic Tasks” and go to “Advanced”. Then select on “Single Snapin”. I select my software and tell it to “Schedule Instant Deployment” and create the task. From there I can go to “Task Management” at the top and see the task there, but it sits at queued. I’ve waited around 30 minutes and it never progresses. The fog.log file under the C:\ doesn’t show anything. I’ve tried restarting the FOG service and rebooting the entire computer, but it never goes beyond queued.

    I did find one thread that wanted you to run the MySQL commands “truncate table snapinJobs;” and “truncate table snapinTasks;”. I ran that once and the job did go through and completed. But as soon as uninstalled Chrome, restarted the computer and re-ran the task again, it would sit at queued. I then tried the MySQL commands again and those don’t work anymore.

    Any help is greatly appreciated.



  • Good morning, Tom. The .msi file for Google Chrome is roughly 43 MB. Although I did follow the wiki on editing the php.ini file and increasing the “memory_limit”, “post_max_size”, and “upload_max_file_size” to 1900 M.

    Could I have screwed up the php.ini file and it’s causing this issue somehow? I (of course) didn’t make a backup before editing it, but i’m sure I can find a default, out-of-the-box php.ini to replace it with.


  • Senior Developer

    How big is this snapin file? My guess is it’s trying to read the contents of the file into memory. PHP defaults to a cap of 128MB, is the snapin file larger than this?



  • Thanks for the reply Joseph. I have tried that as well, but it still says queued, so I don’t think it’s my syntax causing the issue.


  • Testers

    Chrome has a special enterprise installer available here. Your runwith command is msiexec, the run with argument is /i and the command line switches are /qn.


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.