SOLVED Setting up new storage node

  • And obviously add the new location to your Storage Management area as a new master node (in it’s own group as well)

    And I agree with @ITSolutions , it’s probably a very bad idea to try to use NTFS. I’d recommend Ext4 as he did.

  • After the new drive is formated and mounted and you can SEE it in the linux system,

    open the CLI, go to the new image directory (wherever you mounted it)

    create a .mntcheck file there, then create the dev folder and a .mntcheck file in there.

    touch .mntcheck;mkdir dev;touch dev/.mntcheck

    The new directory needs 777 permissions assigned to it recursively as well (you may change this later after it’s working)

    I’m keeping my instructions and commands here generic so that this can help others.

    chmod -R 777 /the/path/to/your/new/hdd/mount/goes/here

    Then you need to add the new images and new dev folders to the exports file:

    vi /etc/exports

    You’ll see the two lines in there already for your old local storage node. They will have IDs, and in 1.2.0 they start at 1.
    Copy those two lines, change the IDs to 3 and 4. Modify the paths so they are correct.

    Then either reboot or restart NFS and RCP.

  • @ITSolutions I did what you said. formatted for Ext4 (same as Root). I am getting the same error.


    Ext 4 does not allow me to create new folders so this time i just made the location /Fogdrive

  • Testers

    If you formatted it as NTFS that is the start of your issues. It needs to be ext2, 3, or 4 in order to work correctly with FOG. Try reformatting and mounting it as ext 4 and see if that fixes your issue.