Problem with iPXE booting to Fog: "/default.ipxe permission denied"



  • Hi all,

    I’ve just installed Fog 1.2.0 on Ubuntu 14.04 LTS.

    Had a bit of a problem with the TFTP server, but I’ve now got that working - to the point where, from a Windows machine on the same network, I can run tftp 192.168.X.X get default.ipxe and the output is Transfer successful: 305 bytes in 1 second(s), 305 bytes/s.

    DHCP is set up correctly I believe:

    iPXE dhcp.jpg

    However… when our network machines try to boot, it gets so far then errors out with this message before booting into Windows:

    iPXE problem.jpg

    The difference appears to be the starting slash. If I run tftp 192.168.X.X get /default.ipxe the output is Error on server : Access violation Connect request failed.

    Any idea why iPXE is trying to access /default.ipxe rather than just default.ipxe, or is this symptomatic of a bigger problem?

    Thanks in advance


  • Senior Developer

    Cool, so I’ve solved this thread then. Thanks for reporting back.



  • @Tom-Elliott said:

    @dwr When you access your fog server GUI, what is the URL you go to?

    If you go to the url: http://192.168.3.250/fog/service/ipxe/boot.php what does it give you?

    Well… I have no idea what’s going on now really, but I’ve changed the config again (it wasn’t the root bit that was important, I was missing -s from the server args)… and then when I was checking the MySQL username/password, I found that MySQL had bugged out. I restarted the service and I can boot to FOG!

    Woo :)



  • @Uncle-Frank

    fog@AHSFOG01:/tftpboot$ ls -al /tftpboottotal 5496
    drwxrwxrwx  3 fog  root   4096 Sep 28 16:43 .
    drwxr-xr-x 26 root root   4096 Sep 28 13:07 ..
    -rwxrwxrwx  1 fog  fog     409 Sep 28 16:43 6ys27yKB.html
    drwxrwxrwx  2 fog  fog    4096 Sep 28 16:42 backup
    -rwxrwxrwx  1 fog  fog     587 Sep 28 16:43 bfrnNTeB.html
    -rwxrwxrwx  1 fog  root    840 Sep 28 16:43 boot.txt
    -rwxrwxrwx  1 fog  root    295 Sep 28 13:07 default.ipxe
    -rwxrwxrwx  1 fog  fog  190720 Sep 28 16:43 intel.efi
    -rwxrwxrwx  1 fog  fog   91974 Sep 28 16:43 intel.kkpxe
    -rwxrwxrwx  1 fog  fog   92022 Sep 28 16:43 intel.kpxe
    -rwxrwxrwx  1 fog  fog   92091 Sep 28 16:43 intel.pxe
    -rwxrwxrwx  1 fog  fog  913184 Sep 28 16:43 ipxe.efi
    -rwxrwxrwx  1 fog  fog  849920 Sep 28 16:43 ipxe.iso
    -rwxrwxrwx  1 fog  root 329970 Sep 28 16:43 ipxe.kkpxe
    -rwxrwxrwx  1 fog  root 330018 Sep 28 16:43 ipxe.kpxe
    -rwxrwxrwx  1 fog  root 329464 Sep 28 16:43 ipxe.krn
    -rwxrwxrwx  1 fog  root 330050 Sep 28 16:43 ipxe.pxe
    -rwxrwxrwx  1 fog  fog  123448 Sep 28 16:43 ldlinux.c32
    -rwxrwxrwx  1 fog  fog  187820 Sep 28 16:43 libcom32.c32
    -rwxrwxrwx  1 fog  fog   26468 Sep 28 16:43 libutil.c32
    -rwxrwxrwx  1 fog  root  26140 Sep 28 16:43 memdisk
    -rwxrwxrwx  1 fog  fog   29208 Sep 28 16:43 menu.c32
    -rwxrwxrwx  1 fog  fog   43186 Sep 28 16:43 pxelinux.0
    -rwxrwxrwx  1 fog  root  16794 Sep 28 13:07 pxelinux.0.old
    -rwxrwxrwx  1 fog  fog  190336 Sep 28 16:43 realtek.efi
    -rwxrwxrwx  1 fog  fog   92905 Sep 28 16:43 realtek.kkpxe
    -rwxrwxrwx  1 fog  fog   92953 Sep 28 16:43 realtek.kpxe
    -rwxrwxrwx  1 fog  fog   92944 Sep 28 16:43 realtek.pxe
    -rwxrwxrwx  1 fog  fog  189696 Sep 28 16:43 snp.efi
    -rwxrwxrwx  1 fog  root 189856 Sep 28 16:43 snponly.efi
    -rwxrwxrwx  1 fog  root  91607 Sep 28 16:43 undionly.kkpxe
    -rwxrwxrwx  1 fog  root  91655 Sep 28 16:43 undionly.kpxe
    -rwxrwxrwx  1 fog  root 382650 Sep 28 13:07 undionly.kpxe.INTEL
    -rwxrwxrwx  1 fog  root  91640 Sep 28 16:43 undionly.pxe
    -rwxrwxrwx  1 fog  root  29728 Sep 28 16:43 vesamenu.c32
    

  • Senior Developer

    @dwr When you access your fog server GUI, what is the URL you go to?

    If you go to the url: http://192.168.3.250/fog/service/ipxe/boot.php what does it give you?



  • @Tom-Elliott said:

    @dwr Pretty much yes.

    OK I’ve tried those files and nothing has changed.

    I’ve just had a look at my /etc/xinetd.d/tftp and the config doesn’t quite match up with the settings I found here: https://wiki.fogproject.org/wiki/index.php/Unable_to_connect_to_TFTP

    My config has the user set as nobody. If I change that to root and then restart the xinetd serivce, I get an entirely different error:

    iPXE problem 2.jpg

    So… does that mean it could be permissions?


  • Senior Developer

    @dwr Pretty much yes.



  • @Tom-Elliott apologies for being a moron, would it literally just be a case of replacing the files in my /tftpboot folder with those in trunk?


  • Senior Developer

    I think it would yeild you much better results. You could even just try the files we have in trunk for ipxe. They are found in:

    https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp



  • @Tom-Elliott said:

    @dwr I’ve seen this problem on numerous occasions. What you’re seeing isn’t necessarily what is actually going on. It’s trying to load the files but it tries to do so improperly. This does not happen on all systems though. And because of the nature of the problem, seemingly specific to debian OS’s I’ve made corrections for this in trunk/dev versions of fog. Please give that a shot.

    Sorry pal, when you say “give that a shot”, do you mean downloading the latest dev version of Fog and installing that instead?


  • Developer

    @dwr On my system it does not matter if I get ‘default.ipxe’ or ‘/default.ipxe’. Both get properly downloaded. Maybe it’s just file permisson problem.

    ls -al /tftpboot
    ...
    

  • Senior Developer

    @dwr I’ve seen this problem on numerous occasions. What you’re seeing isn’t necessarily what is actually going on. It’s trying to load the files but it tries to do so improperly. This does not happen on all systems though. And because of the nature of the problem, seemingly specific to debian OS’s I’ve made corrections for this in trunk/dev versions of fog. Please give that a shot.


  • Moderator

    @dwr Network machines are on the same network ?


Log in to reply
 

395
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.