Unable to replicate image on storage node



  • Hey guys, I just installed FOG and I’ll start by saying I think it is literally amazing.

    That said, I have run into a problem. I have a master node, and had just set up a second node (named Bones) on the network. But the master node is not replicating its image stores onto the second node. When I press CTRL+ALT+F3, I see the following messages (I haven’t included the time stamps).

    Starting sync.
    Syncing: Bones
    Subprocess -> mirror:Login failed: 503 Login with USER first.
    Subprocess -> etc
    Subprocess -> Complete

    It does that every 10 minutes, when the master node is supposed to be polling its slave nodes.
    How do I fix this?



  • I have experienced the same problem, besides, a username and a password didn’t appear when finishing the Storage Node installation.
    What I did to get it working is to change the password in the Storage Node at the /opt/fog/.fogsettings as well as in the main FOG server at the WebUI -> Storage Management -> All Storage Nodes -> “Your-Storage-Node” -> Management Password, so that both match the local user’s password. I can’t say if it is the Storage Node’s or the main FOG server’s local user, as I have the same password in both machines.
    I think it is the same solution as wpsd’s, but instead of changing the local user’s password to match the one at .fogsettings I have changed it in .fogsettings to match the local user’s password.



  • The storage node. The password was the same in the UI under the new storage node and .fogsettings but setting it for the local user using ‘passwd fog XXXXX’ is what did the trick.


  • Moderator

    [quote=“wpsd, post: 5195, member: 1641”]FWIW, I was having the same issue until I set the password of the ‘fog’ user on the second node to what was displayed in /opt/fog/.fogsettings. Sync began immediately after I restarted the replicator service.[/quote]

    To which /opt/fog/.fogsettings are you referring? The one on the main FOG server or the storage node?



  • FWIW, I was having the same issue until I set the password of the ‘fog’ user on the second node to what was displayed in /opt/fog/.fogsettings. Sync began immediately after I restarted the replicator service.



  • That might be a good plan, I would really appreciate it, when would be a good time? (I am on Central Daylight Time) [url]http://en.wikipedia.org/wiki/Central_Daylight_Time[/url]


  • Moderator

    When the storage node is first installed using the “S” option in the Fog Installer, it creates the fog user and password and the rights it needs to allow tftp access to the storage node (itself). Once you tell the main "N"ormal Fog server what the IP, management username and password are, tftp FROM the main server TO the storage node should work. If you’d like some help, maybe we could do a join.me session or other remote support and I could look through your fog setup.



  • Oh yeah, I think I have memorized large chunks of the wiki, LOL (oops, didn’t realize that was in your signature, did find the donate link though ;))

    I had another storage node up and running after I followed the advice in this thread along with a few others (MySQL IP binding, etc). It had a software RAID though which kept becoming degraded so I decided to go with a different box that wouldn’t need a software RAID.

    The first one I had running I was using Linux Mint 13, now I have switched to using Ubuntu Server. The fact that it uses tftp instead of FTP might be helpful as I wasn’t aware of that.

    Since this is a login issue, are there other places (configuration files) that contain the username and password? Also, is there a file similar the the “ftpusers” file for tftp protocol? Or should I just try to start from scratch again?


  • Moderator

    On the Main/Primary/Master fog server, you define other storage nodes in the the storage group. When you define the new storage node, you need to supply the tftp username and password so that your main server can push image files to the other storage servers. The management username/tftp username is almost always “fog”. The management password is generated when you install the new server in “S” mode rather than “N” mode and is stored in the .fogsettings file on the new storage server.

    If you open the .fogsettings on the storage node and get the password out, you can then log in to the webUI for the main fog server and define the new storage node using the Management username “fog” and password from the .fogsettings of the storage node.



  • I am in somewhat the same pickle as the poster above. I am receiving the “530 Login Incorrect”

    I have checked the password in the config.php, .fogsettings, and also made sure that the user account “fog” on the storage node has the same password. Also that it has permissions on the /images/ folder, although I am not getting a permission error (yet).

    This is the fogreplicator.log from my fog server:

    [CODE][07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Starting service loop.
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Checking if I am the group manager.
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] I am the group manager.
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Starting Image replication.
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Determining my group ID number.
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Looking up my node ID number
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] NODE ID# 1
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] We are group ID: #1
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Finding group members.
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Found: 1 other member(s).
    [07-25-12 3:31:24 pm]
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Getting my image root.
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] My Root: /images
    [07-25-12 3:31:24 pm]
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Starting Sync.
    [07-25-12 3:31:24 pm] * [07-25-12 3:31:24 pm] Syncing: fogstorage1
    [07-25-12 3:32:00 pm] * [07-25-12 3:32:00 pm] SubProcess -> mirror: Login failed: 530 Login incorrect.

    [07-25-12 3:32:00 pm] * [07-25-12 3:32:00 pm] SubProcess ->
    [07-25-12 3:32:00 pm] * [07-25-12 3:32:00 pm] SubProcess -> Complete[/CODE]


  • Moderator

    For a storage node to work, it needs two things. A valid connection to the main mysql database so it can check it’s status (and maybe other things). This should be setup when you choose the “S” install type and complete the setup wizard. In the wizard, it asks for the username and password for the main mysql database, usually username is fogstorage and password is something like “fsXXXX” where XXXX is between 0000 and 9999 randomly.

    You only have to update your mysql configuration if the mysql engine does not allow connections from remote hosts, such as on ubuntu 10.04 LTS.

    The problem you seem to be having is the ftp connection to from the MAIN fog server to the Storage Node. The main fog server PUSHES the images to the storage nodes, so it has to know a valid username and password for each different storage node for the file transfer to work. The storage node determines the password, but the username is always “fog”.

    Example: On your [B]storage node[/B] the /opt/fog/.fogsettings file has a password of “1234abcd”.

    When you login to the Web UI of Fog on the [B]Main[/B] Fog server and define the [B]new storage node[/B](not defaultMember, but a new one), the Management Username is “fog” and the Management Password is “1234abcd”

    Do not change the Management username or password for the defaultMember storage node.

    Once you have the correct Management Username and Management Password in the storage node definition, you can restart the FOGImageReplicator service and watch the log file to see if you continue to get an error.



  • I will try it again but I have tested the mysql connection into the main FOG Server and that works remotely, (logging in from computer outside my network). The one thing I noticed was on the Storage Fog Server it did not setup mysql and the webscreens don’t want to load. I don’t think mysql needs to be setup on the Storage node since it is just getting the images from the main fog server and not actually serving anything to the clients but thought I would mention it.

    As mentioned in my first post, I took the password out of the .fogsettings and put that in for the Maintenance username and password for the Storage node on the main fog server. Thank you for testing for me. I am sure there is something I am missing, so I will follow the steps again and see what i find. I was thinking that perhaps the problem is not the mysql connection but the FTP connection into the storage node so that it can send the images to it. I will see if i can test the FTP connection into the storage node server.


  • Moderator

    Looking back up at the previous posts, the error “SubProcess -> mirror: Login failed: 503 Login with USER first” means you probably don’t have the Management username and password specified in your storage node definition.

    If you don’t have the correct Management username and password in your storage node definition, you should see an error “SubProcess -> mirror: Login failed: 530 login incorrect”


  • Moderator

    Ok. This is what I’ve found in my Ubuntu 10.04 LTS Server running Fog 0.32.

    1. Update MySQL to allow connections from remote hosts. On the main Fog server, edit /etc/mysql/my.cnf changing the line: bind-address = 127.0.0.1 to bind-address = [ip of server]
    2. On the storage node, make sure the file: /opt/fog/service/etc/config.php has the fogstorage username and password to match the values from your main server. (Fog Web UI, Other Settings, Fog Settings, FOG Storage Nodes username and password).
    3. On the storage node, open up the /opt/fog/.fogsettings and get the password from the line: password=“somepassword”;
    4. On the main server, fog Web UI, define a new storage node (or update the one that is not working). Put in all the information like name, ip address, max clients, DO NOT CHECK “is master node” - see warning near box, select the storage group (default usually), image location to “/images/”, check “Is Enabled”, and put in the Management username as “fog” and management password as the value we got from the /opt/fog/.fogsettings file.
    5. On the main fog server, run: sudo service FOGImageReplicator restart
    6. On the mian fog server, run: tail -f /opt/fog/log/fogreplicator.log
    7. verify your images start syncing.

  • Moderator

    working on it now in VirtualBox.



  • did you get a chance to setup another storage node??


  • Moderator

    Let me setup another storage node and see what we need. I’m pretty sure you have to sync the usernames and passwords between the storage servers so they can talk, I just don’t know exactly where yet.



  • [quote=“chad-bisd, post: 4124, member: 18”]What version of Fog are you running and on what OS?[/quote]
    Well I am running FOG 0.32 under Ubuntu 11.04 and having the same problem as Michael. When installing the storage node it did not give me the username and password but I found online that I could find that by going to /opt/fog/.fogsettings , however i keep getting the LOGIN Failed message when it is trying to replicate from the Main Fog server to the Storage Node


  • Moderator

    What version of Fog are you running and on what OS?


Log in to reply
 

788
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.