Host registration does not work (FOG r4682)



  • I am using the newest FOG revision (SVN) and can neither register to host anymore nor can I use services like retrieving system information. Whenever I try to e.g. register to host from the ipxe boot menu the registration process altogether seems to be skipped completely and the normal boot menu appears. When I use FOG 1.2.0 it works without any problems though. If I add the client pc manually via MAC address in FOG, the ipxe boot menu shows the client to be registered but if I schedule a simple task (e.g. get system information) the task is not executed.

    I’m running FOG on Ubuntu 12.04.5 in a VM (Virtualbox) while the client PC is a (real) physical pc. Also when I create an additional VM and use it as client and try to register that client to host I get the error message: FATAL: INT18: Boot failure.

    I have already tried restarting all services, nothing helped. Does anyone have a suggestion on what the problem might be?

    Thanks. :)



  • @Wayne-Workman @Tom-Elliott Solved the problem. Somehow curl had a problem with me being behind a proxy, no idea why though, never had this problem before. As a result, bzimage, bzimage32, init.xz and init_32.xz were not downloaded correctly. I solved this problem by using wget to manually download those files (the download links are in /lib/common/functions.sh).

    Also another problem in /lib/common/functions.sh: I was not able to add the repository for php5-5.6, so I had to comment out those lines. In my case this is not a problem, as I’m now using Ubuntu 15.04, which already has php 5.6 preinstalled (at least if you dist-upgrade and update).

    Thanks again for the very fast help. :)



  • @Wayne-Workman Ok I installed everything on Ubuntu 15.04 now, still exactly the same problem. :(



  • Ok I will test it. Thanks for the fast answer. :D


  • Moderator

    @Asthea You tried installing fog trunk on ubuntu 12.04 ? That is probably why it’s not working. Try ubuntu 14 or 15.


Log in to reply
 

375
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.