Unable to Create Download Task from NAS-stored image



  • Hello,

    I posted originally in an older topic but am now creating a new topic for this issue, as I am just finding time to come back around to it.

    I am attempting to use a Synology NAS for the storage of my FOG server’s images. I am able to successfully upload images to the NAS, however I am unable to then deploy those images, receiving the error “You must first upload an image to create a download task.”

    I am using FOG Trunk Git version 4660 on Ubuntu 15.04.

    My pertinent storage node information is as followed:

    Storage Node Name: [NAME]
    IP Address: [NAS IP Address]
    Web root [NAS IP Address] (Is this correct?)
    Image Path: [NFS path to Images folder on the NAS]
    FTP Path: [Identical to Image Path] (Is this correct?)
    Management Username: fog
    Management Password: [password for fog user on the NAS]

    Per the documentation at https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Credentials_.2F_Passwords, all passwords mentioned on that page are identical. Additionally, the fog user on the NAS also has that same password.

    I am able to successfully FTP from the FOG server to the NAS using the fog user credentials and both upload and download a test text file to the Images folder. Permissions when I do so appear appropriately, and when I do FTP into the NAS from the FOG server using the fog user, I do end up in the Images folder.

    Ultimately, once I upload the image, said image ends up in the /[Images NFS path]/dev/[Machine’s MAC address] folder, which if I’m remembering correctly indicates some failure of FTP.

    Any assistance would be appreciated.

    Thank you,
    Chris Bosman



  • Alright, I got this figured out. Everything was configured correctly on the FOG end, it ended up being a setting on the Synology NAS that I needed to change. I had to enable SFTP. Once that was enabled, everything began working correctly.



  • @Wayne-Workman said:

    @Chris-Bosman said:

    Wayne,

    Going into the folder where my images are to be stored on the NAS via the command line and running pwd, the path I get is “/volume1/Workstation_Images”. The lowest directory I can get to on the NAS simply displays as “/”.

    To me, this would suggest that “/volume1/Workstation_Images” is the proper path? Am I correct in assuming that? Because I’ve attempted using that path and still receive the error.

    For FTP credentials, I am using the same user name and credentials in the following locations. This has been the case since the start:

    • On the Synology NAS box, which as read/write privileges over the Workstation_Images folder
    • Under Management Username & Management Password for the storage node.
    • Under FOG_TFTP_FTP_USERNAME/FOG_TFT_FTP_PASSWORD
    • For the FOG Server’s “fog” user
    • In the file /opt/fog/.fogsettings under storageftpuser/storageftppass

    So close.

    On a windows machine at a command prompt, you can FTP into your FOG box.

    Like this:

    upload-f61bf509-55ef-46d3-8afe-2e9276ca0bbb

    There are more details here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Try_to_get_a_file_with_Windows:

    So, the path you found was the disk path, via CLI on the server itself. I’m asking you to figure out your “FTP Path”

    Wayne,

    Following the instructions in the linked Troubleshooting document does not work with the instructions provided. Most commands using Windows Command Line give me an error of “500 PORT/EPRT (Active Mode/Extended Active Mode) is not supported. Use PASV/EPSV instead of this”. This includes attempting to use “ls” to list any directory or using “cd”. Using “pwd” to list the directory gives me an answer of “’/’ is current directory.”

    I did, however, find the Workstation_Images folder by randomly inputting some cd commands. Getting into that folder and requesting the filepath gave me “’/Workstation_Images’ is current directory”. This would be helpful, except I’ve already attempted using both “/Workstation_Images” and "Workstation_Images’ (without the leading /) as my FTP Path.

    Any advice on where to go from here?

    • Chris

  • Moderator

    @Chris-Bosman said:

    Wayne,

    Going into the folder where my images are to be stored on the NAS via the command line and running pwd, the path I get is “/volume1/Workstation_Images”. The lowest directory I can get to on the NAS simply displays as “/”.

    To me, this would suggest that “/volume1/Workstation_Images” is the proper path? Am I correct in assuming that? Because I’ve attempted using that path and still receive the error.

    For FTP credentials, I am using the same user name and credentials in the following locations. This has been the case since the start:

    • On the Synology NAS box, which as read/write privileges over the Workstation_Images folder
    • Under Management Username & Management Password for the storage node.
    • Under FOG_TFTP_FTP_USERNAME/FOG_TFT_FTP_PASSWORD
    • For the FOG Server’s “fog” user
    • In the file /opt/fog/.fogsettings under storageftpuser/storageftppass

    So close.

    On a windows machine at a command prompt, you can FTP into your FOG box.

    Like this:

    upload-f61bf509-55ef-46d3-8afe-2e9276ca0bbb

    There are more details here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Try_to_get_a_file_with_Windows:

    So, the path you found was the disk path, via CLI on the server itself. I’m asking you to figure out your “FTP Path”



  • Wayne,

    Going into the folder where my images are to be stored on the NAS via the command line and running pwd, the path I get is “/volume1/Workstation_Images”. The lowest directory I can get to on the NAS simply displays as “/”.

    To me, this would suggest that “/volume1/Workstation_Images” is the proper path? Am I correct in assuming that? Because I’ve attempted using that path and still receive the error.

    For FTP credentials, I am using the same user name and credentials in the following locations. This has been the case since the start:

    • On the Synology NAS box, which as read/write privileges over the Workstation_Images folder
    • Under Management Username & Management Password for the storage node.
    • Under FOG_TFTP_FTP_USERNAME/FOG_TFT_FTP_PASSWORD
    • For the FOG Server’s “fog” user
    • In the file /opt/fog/.fogsettings under storageftpuser/storageftppass

  • Moderator

    @Chris-Bosman said:

    Tom,

    I have tried “/Workstation_Images” and simply “Workstation_Images” as the ftp path and have had no luck. The images still end up in the /[NFS path]/dev/[MAC address] folder.

    It sounds like you have a mixture of FTP Path and FTP Credentials problems.

    So, to find out the correct path, you simply manually connect via Command Line Interface to the synology NAS via FTP.

    You would then figure out what directory is the “root” directory, the lowest you can go via your FTP session. Then, from there, figure out the path to the /images directory. that path is your FTP path - it will be different from the synology NAS’s ACTUAL path, this is specific to Synology NAS boxes.

    And for the FTP credentials part, just make sure that in your storage node settings, you have a user and pass that actually exists on the Snynology BOX, and that user has permission over the /images directory.

    Here’s a article on FTP, I really should add a bit in it about FTP Path. https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP



  • Tom,

    I have tried “/Workstation_Images” and simply “Workstation_Images” as the ftp path and have had no luck. The images still end up in the /[NFS path]/dev/[MAC address] folder.


  • Senior Developer

    Remove the volume1 for the FTP path.



  • What does it need to be changed to?

    To be specific, my Image Path is /volume1/Workstation_Images, as is my FTP path.


  • Senior Developer

    @Chris-Bosman No, the FTP path for Synology NAS needs to be changed.


Log in to reply
 

368
Online

38983
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.