[r4642] Database is not updated after certain settings change



  • I upgraded to r4642 to get the fix for the Auto Log Out module, and that works great now (thanks again). However, I’m having issues getting some of my settings changes to stick.

    SYMPTOMS: When I adjust certain settings (e.g. the timing for Auto Log Out), FOG will say that the settings have been updated, but nothing has in fact changed. After the page reloads, all the settings are the same. This seems to apply to any global settings page.

    However, this problem is not across the board. I can still adjust the service settings for individual hosts, and that works fine. I can also create tasks for hosts, but these tasks will not remove themselves upon completion, and I am unable to manually remove from the tasks page (once again, FOG says it has made the update, but on reload the task is still there).

    I have also tried several backups of my database (from before the upgrade to r4642), and the behavior remains the same.

    I also wiped the database and attempted to have the installer recreate the schema, but it loaded a white screen with a short error message indicating the update did not work.

    So that’s where I’m at now.



  • Okay, it’s working now. Thanks again for all your help.


  • Senior Developer

    Should be fixed. I’m trying to narrow down on another bug. I’m sorry this caused some grief.


Log in to reply
 

459
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.