Fog 4577 has a blank page when trying to create images.



  • I saw there was another person with the same issue but my error msg from the apache server was different so thought I should open a new forum.
    I am using Ubuntu 14.04 and just updated to 4577. Everything was working fine till update.

    The error is

    198.248.9.129:36162] PHP Fatal error: Call to a member function get() on null in /var/www/html/fog/lib/pages/ImageManagementPage.class.php on line 164, referer: http://198.248.9.129/fog/management/index.php?node=image
    [Tue Sep 08 08:04:21.745068 2015] [:error] [pid 3303] [client


  • Senior Developer

    I’m sorry that I’m not right on the case.

    I wonder about this issue. The specifics of the problem you’re running into seems, to me, to indicate that there is no Storage groups with a master node within the group. Normally it should default to return the relative node that IS in that particular group, but if there is no node associated, this could occur, I suppose. I don’t know all the specifics. I’m working, hopefully, to figure out a solution, but I feel I may need access to a problematic system so I can work on it live. Sometimes, and there are multiples who can verify this as needed, I simply can’t replicate so seeing the problem on a known “bad” target is really the best option.



  • Any idea how to fix this problem yet?


  • Moderator

    It’s very likely that it’s just a bug - and I’m almost positive that @Tom-Elliott is already working on it. Just sit tight.


Log in to reply
 

470
Online

38916
Users

10688
Topics

101382
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.