[git 4577] Create new image page is blank



  • Hi all,
    I built a new fog VM last week using v1.2 then upgraded to trunk.
    Started at 4571 and am now at 4577.
    With each trunk version I installed I would always get a blank page when choosing to create a new image.
    I was able to create a new image using v1.2 though.
    I can also import images using a csv.
    (side question: Is there a way to specify a storage group in the csv?)

    I am using a separate storage server (4571)
    Everything else seems to be working fine.
    (much better than previous server actually)
    I can image computers and all other pages seem to be working normally.

    CentOS 6.7
    iptables and selinux disabled
    No other services installed on the server besides what was needed for fog.

    Any thoughts?



  • @Wayne-Workman yes, as long as I set the local server storage node to master, the create new image page works.
    I also have my fognode1 server, in a different storage group, set to master.


  • Moderator

    @richtm is it working now?



  • @Wayne-Workman Which is exactly why I didnt have the local server set to master.
    I seem to remember that in previous versions of FOG it wasnt necessary to have it enabled at all.
    (unless of course you wanted to do replication)
    And since I only have one storage node at this point I dont need to technically have a master.

    I dont know if this is a change, a feature or “working as intended”, but as long as there is a way to make it work im happy :)


  • Moderator

    @richtm in order for replication to occur properly, yes you need one master in each group - but no more than one. Whatever is on the master will be replicated to the others in the group. Anything on the others that isn’t on the master gets cleared. Therefore, if your master is blank, then all the others go blank too… so be careful.



  • @Tom-Elliott OK, so your comment on the other users post pointed me in the right direction.
    I have two storage groups: “default” and “Fog Storage”.
    Within default is just Local Server - I dont have any images on the local server.
    That node is NOT set to master.
    Within “Fog Storage” I have “FogNode1” which is set to master for that group, and is the only node for now.

    So I went to the Local Server node and set it to master and viola, I can create images again.

    I assume therefore that every group must have a node set to master?
    Is it also safe to assume that setting one node to master will have no affect on nodes in a different group?
    (thats how the warning reads to me, but just want to double check to be sure)
    I shut down my storage server while performing this test just in case.



  • php error.

    [Tue Sep 08 09:00:10 2015] [error] [client 192.168.3.0] PHP Fatal error: Call to a member function get() on null in /var/www/html/fog/lib/pages/ImageManagementPage.class.php on line 164, referer: http://fogserver/fog/management/index.php?node=image
    BFD: /var/www/html/fog/service/ipxe/bzImage: Warning: Ignoring section flag IMAGE_SCN_MEM_NOT_PAGED in section .bss
    BFD: /var/www/html/fog/service/ipxe/bzImage32: Warning: Ignoring section flag IMAGE_SCN_MEM_NOT_PAGED in section .bss


  • Senior Developer

    What is your apache error logs telling you?


  • Moderator

    Right after you hit the blank page - can you then go to the logs area and copy any errors in there to here?
    FOG Config -> Log Viewer -> Apache errors.


Log in to reply
 

359
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.