Setup Issues and Error PXE E53



  • Hi guys,

    I’m having some issues with getting Fog setup properly for my in environment. Currently, we are running Fog 0.32 on Ubuntu 10.04 server, but have decided to upgrade to Fog 1.2.0 on Ubuntu 14.04 server.

    Things I should probably note about our infrastructure. We have no control over the DHCP server beyond we can please a ticket to have static IPs assigned. We also run Fog inside of a VM which runs on an ESXi host (for the sake of testing I running Fog inside of a VM on my iMac using the bridged ethernet network connection). We do have our own subnet and I have to make sure that we broadcast only to our subnet.

    I have looked at a few different setups, but nothing seems to be working.
    From the Fog Wiki:
    Fog on Ubuntu 14.04
    Using FOG with no DHCP Server

    From External Sources:
    FOG – Installing and Troubleshooting FOG 1.2.0 on Ubuntu 14.04 -> This guide was awesome with the details, but still didn’t work in the end. FOG – Installing and Troubleshooting FOG 1.2.0 on Ubuntu 14.04
    FOG Update – Part 4

    I should also note as far as I can tell the only difference between my setup and older one(which my boss created) is that 10.04 uses LTSP and my 14.04 doesn’t.

    My “lstp.conf” file:

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe,130.18.192.41,130.18.192.41
    dhcp-no-override
    pxe-prompt="Press F8 for boot menu", 3
    pxe-service=X86PC, "Boot from network", undionly
    pxe-service=X86PC, "Boot from local hard disk", 0
    dhcp-range=130.18.192.41,proxy,255.255.254.0
    
    

    The static IP for the VM was set properly and is still communicating with the outside world properly. I’m not sure if there is an issue with the dnsmasq setup, tftp, or something else that I overlooked.



  • @Wayne-Workman

    Also, in the file “dnsmasq.conf” at the end of the file uncomment the conf-dir.

    It should look like this:

    # Include another lot of configuration options.
    #conf-file=/etc/dnsmasq.more.conf
    conf-dir=/etc/dnsmasq.d
    


  • @Wayne-Workman

    The credit can really go to my boss, but this is how it ended up working.

    For the FOG setup on Ubuntu 1.2.0

    Follow this guide: https://wiki.fogproject.org/wiki/index.php?title=Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server

    • Skip the “Additonal Steps for 12.04.4, 12.04.5, 14.04, 14.10” section

    The ltsp.conf should look like this:

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe,{server name},{static server ip}
    dhcp-no-override
    pxe-prompt="Press F8 for boot menu", 3
    pxe-service=X86PC, "Boot from network", undionly
    dhcp-range={static server ip},proxy
    

    Make the following changes to the interface order:

    eth*
    lo.inet*
    lo.dnsmasq
    lo.pdnsd
    lo.!(pdns|pdns-recursor)
    lo
    tun*
    tap*
    hso*
    em+([0-9])?(_+([0-9]))*
    p+([0-9])p+([0-9])?(_+([0-9]))*
    ath*
    wlan*
    ppp*
    *
    

    Without these changes DNSMASQ would break DNS lookups.

    Fix MySQL otherwise it’ll wig out on you.

    • Edited /opt/fog/.fogsettings
    snmysqluser="root"
    snmysqlhost="localhost"
    
    • Set the database password
    • Ran sudo dpkg-reconfigure mysql-server-5.5

    Fog services weren’t starting automatically:

    • Changed /etc/rc.local to look like this:
    sleep 10
    service FOGMulticastManager restart
    service FOGScheduler restart
    service FOGImageReplicator restart
    exit 0
    

    For some reason this made it work finally.


  • Moderator

    @Dalton-Childers How? What did you do?



  • @Wayne-Workman @Tom-Elliott

    I just wanted to let you guys know after a few more tries we were able to get FOG working inside our environment.


  • Moderator

    @Dalton-Childers After a session via TeamViewer with Dalton, I found that his virtualized FOG server was not receiving any traffic from anything besides the physical computer it was running on and possibly the internet.

    I did a tcpdump and transfered the file via TFTP to the host computer - and examined it with WireShark. We used the reported MAC address from the FOG server as a filter and a single packet showed up. However without a filter all the traffic from the hosting computer shows up.

    I think that this problem is related to the VM setup on the iMac, and I recommended that Dalton try to install FOG on a physical machine using all the same settings - and see what happens, or to use a physical machine and have his Network Team change the DHCP options 066 and 067 for him so that he doesn’t have to use dnsmasq.

    Just awaiting for a reply at this point to see what path he goes down and how it goes.



  • @Wayne-Workman @Tom-Elliott

    I have created the requested sym-links, but still had no lucky with the PXE boot process.

    10.0.1.2 is the IP address that my wireless card was assigned.
    192.168.2.1 is the IP address of the private network on the iMac or at least that was my understanding. I have never changed that setting as it comes by default with VMware Fusion.

    Has seen below I have created the sym-links:
    TFTP-Permissions-Take2.png

    I also bump the permission to 777. I was reading another FOG posting that suggested that has a possible fix.

    I edited the dnsmasq.d/ltsp.conf file to related the sym-link change.

    ltsp config.png

    I also added in some more lines. I tested the tftp after creating the sym-link and then again after switch to undionly instead of undionly.kpxe.

    I tried to pull the files from the server TFTP on my computer (iMac), my coworkers (PC), and my bosses (Mac Pro). The results were as follows:

    Mine:

    tftp> get 130.18.192.41:undionly.kkpxe
    Received 103224 bytes in 0.0 seconds
    tftp> get 130.18.192.41:undionly.kpxe
    Received 103273 bytes in 0.0 seconds
    tftp> get 130.18.192.41:undionly.0
    Error code 256: File not found
    

    Coworker:

    tftp –i 130.18.192.41 get undionly.kpxe
    Timeout Occurred
         Connection Request Failed
    
    tftp –i 130.18.192.41 get undionly.kkpxe
    Timeout Occurred
         Connection Request Failed 
    

    Wit the Windows machine I also tried to specify a different download location “%HOMEPATH\Downloads\undionly.kpxe” and “%HOMEPATH\Downloads\undionly.kkpxe”. These result failed as well.

    Bosses:

    tftp> get 130.18.192.41:undionly.kkpxe
    Received 103224 bytes in 0.0 seconds
    tftp> get 130.18.192.41:undionly.kpxe
    Received 103273 bytes in 0.0 seconds
    

    I had him run the following line and his results were the same as mine.

    Fun fact, but could me just looking to much into the problem. I downloaded nmap to my iMac and checked port 69 on my FOG server. The result are below:

    nMap-Results.png


  • Moderator

    @Dalton-Childers At first glance of the results of ls -lahRt /tftpboot it would seem that your sym-links are not created, and that you have used copies instead. undionly.0 does not exist. (just informational at this point)

    From your ifconfig output,
    What is 10.0.1.2 ?
    What is 192.168.2.1 ?

    And - try to create this symbolic link and then try to network boot again:
    ln -s /tftpboot/undionly.kkpxe /tftpboot/undionly.0

    Here’s more info on symbolic links: http://www.cyberciti.biz/faq/unix-creating-symbolic-link-ln-command/

    Please do not get discouraged. For many, Linux is a new adventure and the ‘path’ might not be as clear as it might be to an experienced MAC OS or Windows user - but to the experienced Linux user - it’s the same process as any other system… troubleshoot, test, troubleshoot, test - narrow it down, test, troubleshoot, test, narrow it down further, coffee, test, restroom break, test… it’s the same thing. If you know - it’s easy, if you don’t know, you figure it out. If you’re inexperienced - then you either try to figure it out and in the process learn a massive ton of Linux or you simply walk away because you refuse to give the effort… :-\ As long as you keep the communication going here, we will continue to try to help. It’s the same as with anything - if there’s a will there’s a way. No will, no way.



  • @Tom-Elliott @Wayne-Workman said:

    @Dalton-Childers @Tom-Elliott is right, and that was the direction I was heading with this…

    Can you give us the output of this command first - it’ll let us know what’s going on with the sym-link.

    ls -lahRt /tftpboot
    

    Then - We need lots and lots of details about your VM setup because I think that’s where the problem lies. What are you using? How is the network setup? Is it using NAT or is it bonded or NIC sharing or what?

    Can you install traceroute and then run a traceroute against Google’s DNS?

    sudo apt-get install traceroute
    traceroute 8.8.8.8
    

    and give us the output of that please? This will tell us if you are using NAT or not. It’d also help greatly if you’d tell us you Router Address - the address of the target host if you can find it on your router - and perhaps some screen shots of your network setup for the VM?

    Basically - the more details the better.

    First request is listed below in the screen shot. The results of:

    ls -lahRt /tftpboot
    

    TFTP-Permissions.png

    Information about setup:

    I am running the Ubuntu 14.04 VM on my iMac using VMware Fusion 8 Pro. I have set a static IP which is “130.18.192.41” (including image of my network interface config). Our subnet is “255.255.254.0” and the overall range is 130.18.192.1 to 130.18.193.255. The architecture of the network isn’t completely known due to the nature of the main ITS group. Also, we have to be careful not to allow our PXE traffic to appear outside of our subnet. We have our own DNS in house, but the DHCP server is control by the main ITS group which is why I assumed I would need to use dnsmasq.

    network-interfaces.png

    I have included a picture for clarity, but the VM is bridged with the iMac’s ethernet port so it appears as an additional machine.

    NIC-Setup.png

    The IP in the image “130.18.193.107” is the IP that is assigned to my iMac.

    Code box showing the output of ifconfig on my iMac:

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    	options=3<RXCSUM,TXCSUM>
    	inet6 ::1 prefixlen 128
    	inet 127.0.0.1 netmask 0xff000000
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    	nd6 options=1<PERFORMNUD>
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    	options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
    	ether 40:6c:8f:0f:ad:1a
    	inet6 fe80::426c:8fff:fe0f:ad1a%en0 prefixlen 64 scopeid 0x4
    	inet 130.18.193.107 netmask 0xfffffe00 broadcast 130.18.193.255
    	nd6 options=1<PERFORMNUD>
    	media: autoselect (1000baseT <full-duplex>)
    	status: active
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    	ether 7c:c3:a1:9f:df:6c
    	inet6 fe80::7ec3:a1ff:fe9f:df6c%en1 prefixlen 64 scopeid 0x5
    	inet 10.0.1.2 netmask 0xffffff00 broadcast 10.0.1.255
    	nd6 options=1<PERFORMNUD>
    	media: autoselect
    	status: active
    fw0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 4078
    	lladdr 3c:07:54:ff:fe:e6:02:ee
    	media: autoselect <full-duplex>
    	status: inactive
    en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    	options=60<TSO4,TSO6>
    	ether d2:00:1e:60:2e:e0
    	media: autoselect <full-duplex>
    	status: inactive
    en3: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    	options=60<TSO4,TSO6>
    	ether d2:00:1e:60:2e:e1
    	media: autoselect <full-duplex>
    	status: inactive
    p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    	ether 0e:c3:a1:9f:df:6c
    	media: autoselect
    	status: active
    bridge0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    	options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    	ether 42:6c:8f:f0:c0:00
    	Configuration:
    		id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
    		maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
    		root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
    		ipfilter disabled flags 0x2
    	member: en2 flags=3<LEARNING,DISCOVER>
    	        ifmaxaddr 0 port 7 priority 0 path cost 0
    	member: en3 flags=3<LEARNING,DISCOVER>
    	        ifmaxaddr 0 port 8 priority 0 path cost 0
    	media: <unknown type>
    	status: inactive
    vmnet1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    	ether 00:50:56:c0:00:01
    	inet 192.168.192.1 netmask 0xffffff00 broadcast 192.168.192.255
    vmnet8: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    	ether 00:50:56:c0:00:08
    	inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
    

    The results of traceroute:

    traceroute-info.png

    I don’t have access to the routers so I am flying blind on that end.

    If there is anything extra that I should have added please let me know.


  • Moderator

    @Dalton-Childers @Tom-Elliott is right, and that was the direction I was heading with this…

    Can you give us the output of this command first - it’ll let us know what’s going on with the sym-link.

    ls -lahRt /tftpboot
    

    Then - We need lots and lots of details about your VM setup because I think that’s where the problem lies. What are you using? How is the network setup? Is it using NAT or is it bonded or NIC sharing or what?

    Can you install traceroute and then run a traceroute against Google’s DNS?

    sudo apt-get install traceroute
    traceroute 8.8.8.8
    

    and give us the output of that please? This will tell us if you are using NAT or not. It’d also help greatly if you’d tell us you Router Address - the address of the target host if you can find it on your router - and perhaps some screen shots of your network setup for the VM?

    Basically - the more details the better.


  • Senior Developer

    @Dalton-Childers So the simple test, you attempt to get the undionly.kpxe file, then you try to get the undionly.0 file. Because the undionly.kpxe file exists, you’re not seeing an error, but because the undionly.0 doesn’t exist, you’re seeing the error on the second command. This sound correct.

    Now that you know that at the least the tftp server is operating locally. Now we need to see where it breaks down.



  • @Wayne-Workman said:

    @Dalton-Childers Try the TFTP test locally on the FOG server itself. Try to use both the actual IP of the server and then try the local loopback address 127.0.0.1

    Using the IP address of the server (130.18.192.41):

    root@fog:~# tftp 130.18.192.41
    tftp> get undionly.kpxe
    tftp> get undionly.0
    Error code 1: File not found
    

    Due to a lack of experience with TFTP, I am assuming the lack of error for undionly.kpxe means it found the file. I tried undionly.0 because I know the file is not present under /tftpboot/.

    Using the IP address of the server (127.0.0.1):

    root@fog:~# tftp 127.0.0.1
    tftp> get undionly.kpxe
    tftp> get undionly.0
    Error code 1: File not found
    

    Same results as the server’s IP.


  • Moderator

    @Dalton-Childers Try the TFTP test locally on the FOG server itself. Try to use both the actual IP of the server and then try the local loopback address 127.0.0.1



  • @ch3i said:

    @Dalton-Childers said:

    @Wayne-Workman said:

    @Tom-Elliott said:

    @Dalton-Childers You’ve ensured that firewall is disabled on the server?

    Well if he can’t get the plane-jane undionly.kkpxe using TFTP - then there are other issues.

    I was thinking either Firewall or TFTP is not running right or something - I don’t think this is a dnsmasq problem.

    Can you check the status of TFTP and then restart it and then check the status again with these commands?

    service tftpd-hpa status
    service tftpd-hpa restart
    service tftpd-hpa status
    

    Then after you’ve restarted TFTP, please go to another computer and try to get the undionly.kpxe file manually via TFTP again.

    Okay, so I restart the tftpd-hpa service.

    service tftpd-hpa status
    tftpd-hpa start/running, process 1104
    service tftpd-hpa restart
    tftpd-hpa stop/waiting
    tftpd-hpa start/running, process 3039
    service tftpd-hpa status
    tftpd-hpa start/running, process 3039
    

    I tried to get the unidonly.kpxe file again from a windows machine on the network using:

    tftp –i 130.18.192.41 get undionly.kpxe
    

    But I still get back the following error:

    Timeout Occurred
         Connection Request Failed 
    

    tftpd-hpa file

    # /etc/default/tftpd-hpa
    # FOG Modified version
    TFTP_USERNAME="root"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS="0.0.0.0:69"
    TFTP_OPTIONS="--secure"
    

    Which I am wondering if the issue is the root username. Should the username be fog?

    Mine :

    # /etc/default/tftpd-hpa
    # FOG Modified version
    TFTP_USERNAME="root"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS=":69"
    TFTP_OPTIONS="-s"
    

    I updated my tftpd-hpa file to reflect you setup, but sadly it’s still not working.


  • Moderator

    @Dalton-Childers said:

    @Wayne-Workman said:

    @Tom-Elliott said:

    @Dalton-Childers You’ve ensured that firewall is disabled on the server?

    Well if he can’t get the plane-jane undionly.kkpxe using TFTP - then there are other issues.

    I was thinking either Firewall or TFTP is not running right or something - I don’t think this is a dnsmasq problem.

    Can you check the status of TFTP and then restart it and then check the status again with these commands?

    service tftpd-hpa status
    service tftpd-hpa restart
    service tftpd-hpa status
    

    Then after you’ve restarted TFTP, please go to another computer and try to get the undionly.kpxe file manually via TFTP again.

    Okay, so I restart the tftpd-hpa service.

    service tftpd-hpa status
    tftpd-hpa start/running, process 1104
    service tftpd-hpa restart
    tftpd-hpa stop/waiting
    tftpd-hpa start/running, process 3039
    service tftpd-hpa status
    tftpd-hpa start/running, process 3039
    

    I tried to get the unidonly.kpxe file again from a windows machine on the network using:

    tftp –i 130.18.192.41 get undionly.kpxe
    

    But I still get back the following error:

    Timeout Occurred
         Connection Request Failed 
    

    tftpd-hpa file

    # /etc/default/tftpd-hpa
    # FOG Modified version
    TFTP_USERNAME="root"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS="0.0.0.0:69"
    TFTP_OPTIONS="--secure"
    

    Which I am wondering if the issue is the root username. Should the username be fog?

    Mine :

    # /etc/default/tftpd-hpa
    # FOG Modified version
    TFTP_USERNAME="root"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS=":69"
    TFTP_OPTIONS="-s"
    


  • @Tom-Elliott said:

    @Dalton-Childers You’ve ensured that firewall is disabled on the server?

    I disabled the firewall all together.

    Also, I managed to get apt-get working again by following your suggestion to comment out “port=0”.

    Steps:
    Comment out "port=0"
    rm /var/lib/apt/lists/* -vf
    apt-get update



  • @Wayne-Workman said:

    @Tom-Elliott said:

    @Dalton-Childers You’ve ensured that firewall is disabled on the server?

    Well if he can’t get the plane-jane undionly.kkpxe using TFTP - then there are other issues.

    I was thinking either Firewall or TFTP is not running right or something - I don’t think this is a dnsmasq problem.

    Can you check the status of TFTP and then restart it and then check the status again with these commands?

    service tftpd-hpa status
    service tftpd-hpa restart
    service tftpd-hpa status
    

    Then after you’ve restarted TFTP, please go to another computer and try to get the undionly.kpxe file manually via TFTP again.

    Okay, so I restart the tftpd-hpa service.

    service tftpd-hpa status
    tftpd-hpa start/running, process 1104
    service tftpd-hpa restart
    tftpd-hpa stop/waiting
    tftpd-hpa start/running, process 3039
    service tftpd-hpa status
    tftpd-hpa start/running, process 3039
    

    I tried to get the unidonly.kpxe file again from a windows machine on the network using:

    tftp –i 130.18.192.41 get undionly.kpxe
    

    But I still get back the following error:

    Timeout Occurred
         Connection Request Failed 
    

    tftpd-hpa file

    # /etc/default/tftpd-hpa
    # FOG Modified version
    TFTP_USERNAME="root"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS="0.0.0.0:69"
    TFTP_OPTIONS="--secure"
    

    Which I am wondering if the issue is the root username. Should the username be fog?


  • Moderator

    @Tom-Elliott said:

    @Dalton-Childers You’ve ensured that firewall is disabled on the server?

    Well if he can’t get the plane-jane undionly.kkpxe using TFTP - then there are other issues.

    I was thinking either Firewall or TFTP is not running right or something - I don’t think this is a dnsmasq problem.

    Can you check the status of TFTP and then restart it and then check the status again with these commands?

    service tftpd-hpa status
    service tftpd-hpa restart
    service tftpd-hpa status
    

    Then after you’ve restarted TFTP, please go to another computer and try to get the undionly.kpxe file manually via TFTP again.


  • Senior Developer

    @Dalton-Childers You’ve ensured that firewall is disabled on the server?


  • Senior Developer

    If apt-get isn’t working, try commenting (adding a # symbol to the start of a comment) the port=0 line, with #port=0 and restart dnsmasq.


Log in to reply
 

393
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.