Snapin Problems



  • Hey there I am having some trouble deploying snapins. I am on 4499 and currently have a fog webserver and a storage node. The storage node server is set as the default “Master” node and the webserver is set to have a storage node that is in another storage group only for snapins. I added a new snapin and then I tried to add it to my test box (Windows 7) but nothing happens. There weren’t any files in the C:\Program Files (x86)\FOG\tmp directory. Here is the fog.log SnapinClient response

     8/26/2015 9:41 AM Client-Info Version: 0.9.4
     8/26/2015 9:41 AM SnapinClient Running...
     8/26/2015 9:41 AM Middleware::Communication URL: http://172.17.240.1/fog/service/servicemodule-active.php?moduleid=snapinclient&mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&newService=1
     8/26/2015 9:41 AM Middleware::Communication Response: Success
     8/26/2015 9:41 AM Middleware::Communication URL: http://172.17.240.1/fog/service/snapins.checkin.php?mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&newService=1
     8/26/2015 9:41 AM Middleware::Communication Response: No snapins
    

    I also tried without the “Deploy Single Snapin” task but that didn’t work either. So I googled around and found that sometimes the snapinJobs table sometimes had leftover data in it if we had deleted snapins. It had 85 rows of jobs and snapinTasks was empty so I truncated snapinJobs. After that I tried to add a “Deploy Single Snapin” task on my testbox again but it still is getting the “No snapins” response.

    Thanks for the help! This program so far has been amazing to use.



  • No problem, thanks for the swift response and fix!


  • Senior Developer

    Thanks for all the information. I did find that I forgot to add the checks that are specific to Snapin Tasks for the checking that tests if snapins should be deployed or not. This should be good to go. Sorry about not knowing sooner. The permissions issue is most likely really simple.



  • Its a permissions issue for the download, so that’s on my end, it looks like everything is working!



  • Almost there! I freshly imaged the PC after updating to 4505 and the snapin I was trying to install worked. Then I added a second one for Google Chrome and deployed it but it looks like it isn’t downloading the installer after I added the snapin on the web portal.

    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     8/27/2015 11:45 AM Client-Info Version: 0.9.4
     8/27/2015 11:45 AM SnapinClient Running...
     8/27/2015 11:45 AM Middleware::Communication URL: http://172.17.240.1/fog/service/servicemodule-active.php?moduleid=snapinclient&mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&newService=1
     8/27/2015 11:45 AM Middleware::Communication Response: Success
     8/27/2015 11:45 AM Middleware::Communication URL: http://172.17.240.1/fog/service/snapins.checkin.php?mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&newService=1
     8/27/2015 11:45 AM Middleware::Communication Response: Success
     8/27/2015 11:45 AM SnapinClient Snapin Found:
     8/27/2015 11:45 AM SnapinClient     ID: 11
     8/27/2015 11:45 AM SnapinClient     RunWith: 
     8/27/2015 11:45 AM SnapinClient     RunWithArgs: 
     8/27/2015 11:45 AM SnapinClient     Name: UltraVNC
     8/27/2015 11:45 AM SnapinClient     File: UltraVNC_1_2_06_X64_Setup_silent.exe
     8/27/2015 11:45 AM SnapinClient     Created: 2015-08-27 11:50:41
     8/27/2015 11:45 AM SnapinClient     Args: 
     8/27/2015 11:45 AM SnapinClient     Reboot: 
     8/27/2015 11:45 AM Middleware::Communication URL: http://172.17.240.1/fog/service/snapins.file.php?mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&taskid=11
     8/27/2015 11:45 AM Bus {
      "channel": "Notification",
      "data": "{\r\n  \"title\": \"UltraVNC\",\r\n  \"message\": \"FOG is installing UltraVNC\",\r\n  \"duration\": 10\r\n}"
    }
     8/27/2015 11:45 AM Bus Emmiting message on channel: Notification
     8/27/2015 11:45 AM Bus Emmiting message on channel: Notification
     8/27/2015 11:45 AM SnapinClient Starting snapin...
     8/27/2015 11:45 AM SnapinClient Snapin finished
     8/27/2015 11:45 AM SnapinClient Return Code: 1
     8/27/2015 11:45 AM Bus {
      "channel": "Notification",
      "data": "{\r\n  \"title\": \"Finished UltraVNC\",\r\n  \"message\": \"UltraVNC finished installing\",\r\n  \"duration\": 10\r\n}"
    }
     8/27/2015 11:45 AM Bus Emmiting message on channel: Notification
     8/27/2015 11:45 AM Bus Emmiting message on channel: Notification
     8/27/2015 11:45 AM Middleware::Communication URL: http://172.17.240.1/fog/service/snapins.checkin.php?taskid=11&exitcode=1&mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&newService=1
     8/27/2015 11:45 AM Middleware::Communication URL: http://172.17.240.1/fog/service/snapins.checkin.php?mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&newService=1
     8/27/2015 11:45 AM Middleware::Communication Response: Success
     8/27/2015 11:45 AM SnapinClient Snapin Found:
     8/27/2015 11:45 AM SnapinClient     ID: 12
     8/27/2015 11:45 AM SnapinClient     RunWith: 'c:\WINDOWS\system32\msiexec.exe
     8/27/2015 11:45 AM SnapinClient     RunWithArgs: /i
     8/27/2015 11:45 AM SnapinClient     Name: Google chrome
     8/27/2015 11:45 AM SnapinClient     File: googlechromestandaloneenterprise.msi
     8/27/2015 11:45 AM SnapinClient     Created: 2015-08-27 11:50:41
     8/27/2015 11:45 AM SnapinClient     Args: 
     8/27/2015 11:45 AM SnapinClient     Reboot: 
     8/27/2015 11:45 AM Middleware::Communication URL: http://172.17.240.1/fog/service/snapins.file.php?mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&taskid=12
     8/27/2015 11:45 AM Bus {
      "channel": "Notification",
      "data": "{\r\n  \"title\": \"Google chrome\",\r\n  \"message\": \"FOG is installing Google chrome\",\r\n  \"duration\": 10\r\n}"
    }
     8/27/2015 11:45 AM Bus Emmiting message on channel: Notification
     8/27/2015 11:45 AM Bus Emmiting message on channel: Notification
     8/27/2015 11:45 AM SnapinClient Starting snapin...
     8/27/2015 11:45 AM SnapinClient ERROR: Could not start snapin
     8/27/2015 11:45 AM SnapinClient ERROR: The system cannot find the file specified
     8/27/2015 11:45 AM Middleware::Communication URL: http://172.17.240.1/fog/service/snapins.checkin.php?taskid=12&exitcode=-1&mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&newService=1
     8/27/2015 11:45 AM Middleware::Communication URL: http://172.17.240.1/fog/service/snapins.checkin.php?mac=6C:62:6D:D8:45:57||00:00:00:00:00:00:00:E0&newService=1
     8/27/2015 11:45 AM Middleware::Communication Response: No snapins
    ------------------------------------------------------------------------------
    

  • Moderator

    @lhovarter Tom has made some changes - please try updating and see how it goes.



  • The permissions change did not work for me either



  • @Wayne-Workman said:

    Please try this and see what happens:

    chmod -R 755 /var/www/html/fog
    

    and then see what happens.

    Still doing the same thing


  • Moderator

    Please try this and see what happens:

    chmod -R 755 /var/www/html/fog
    

    and then see what happens.



  • I have the same problem, snapins will never be added to the snapintasks or snapinjobs tables when creating a single or all snapins task. They will be added and run normally if created as part of a download task however. I’m running a single Centos 7 server and am on 4501.


  • Moderator

    @lhovarter That’s quite interesting… I think the @Developers need to take it from here. :p



  • Alright I added a snapin to the default group and added a task to deploy it. The task Manager says queued and the webpage is giving me #!ns still. I double checked that I have snapins enabled on the host and globally as well.

    I checked the SQL tables real quick to see if there was anything and got this:

    
    mysql> Select * from snapinJobs;
    +------+----------+-----------+---------------------+
    | sjID | sjHostID | sjStateID | sjCreateTime        |
    +------+----------+-----------+---------------------+
    |    1 |      391 |         0 | 2015-08-26 10:58:30 |
    |    2 |      392 |         0 | 2015-08-26 10:58:30 |
    |    3 |      393 |         0 | 2015-08-26 10:58:30 |
    |    4 |      394 |         0 | 2015-08-26 10:58:30 |
    |    5 |      395 |         0 | 2015-08-26 10:58:30 |
    |    6 |      396 |         0 | 2015-08-26 10:58:31 |
    |    7 |      399 |         0 | 2015-08-26 10:58:31 |
    |    8 |      400 |         0 | 2015-08-26 10:58:31 |
    |    9 |      401 |         0 | 2015-08-26 10:58:31 |
    |   10 |      402 |         0 | 2015-08-26 10:58:31 |
    |   11 |      404 |         0 | 2015-08-26 10:58:31 |
    |   12 |      405 |         0 | 2015-08-26 10:58:31 |
    |   13 |      406 |         0 | 2015-08-26 10:58:31 |
    |   14 |      407 |         0 | 2015-08-26 10:58:31 |
    |   15 |      408 |         0 | 2015-08-26 10:58:31 |
    |   16 |      409 |         0 | 2015-08-26 10:58:31 |
    |   17 |      410 |         0 | 2015-08-26 10:58:31 |
    |   18 |      411 |         0 | 2015-08-26 10:58:31 |
    |   19 |      412 |         0 | 2015-08-26 10:58:31 |
    |   20 |      413 |         0 | 2015-08-26 10:58:31 |
    |   21 |      414 |         0 | 2015-08-26 10:58:31 |
    |   22 |      415 |         0 | 2015-08-26 10:58:32 |
    |   23 |      416 |         0 | 2015-08-26 10:58:32 |
    |   24 |      417 |         0 | 2015-08-26 10:58:32 |
    |   25 |      418 |         0 | 2015-08-26 10:58:32 |
    |   26 |      419 |         0 | 2015-08-26 10:58:32 |
    |   27 |      420 |         0 | 2015-08-26 10:58:32 |
    |   28 |      421 |         0 | 2015-08-26 10:58:32 |
    |   29 |      422 |         0 | 2015-08-26 10:58:32 |
    |   30 |      423 |         0 | 2015-08-26 10:58:32 |
    |   31 |      463 |         0 | 2015-08-26 12:29:45 |
    +------+----------+-----------+---------------------+
    31 rows in set (0.00 sec)
    
    mysql> Select * from snapinTasks;
    Empty set (0.00 sec)
    
    

    I am currently imaging 30 pcs on another floor but they do not have snapins assigned to them if those could be them.



  • Sure, I will give that a try


  • Moderator

    @lhovarter Just to verify your problem, can you attempt to create your snapin within the other storage group and try to deploy that to one computer and just see what happens?



  • truncate table snapinJobs; truncate table snapinTasks;
    Query OK, 0 rows affected (0.00 sec)
    
    Query OK, 0 rows affected (0.00 sec)
    

    Then I went to my host, Clicked Basic Tasks -> Advanced -> Deploy Single Snapin

    I see the task in Active Tasks on the fog website but it is in the “queued” state, not active (don’t know if that matters). Active Snapin Tasks shows nothing.
    and the fog.log is showing the same thing as before and the webpage is still the #!ns code


  • Senior Developer

    That is correct.

    Can you truncate table snapinJobs; truncate table snapinTasks; and try again?



  • Just this:

    #!ns

    I assume that means no snapins to the client program?


  • Senior Developer


Log in to reply
 

369
Online

38983
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.