MAC address not sticking on host



  • So I’m adding some hosts to my fog server, I type it all in, save the host but the MAC address doesn’t stick.

    Keep in mind, I don’t tinker with my fog server. It sits there and runs. The only thing I do is backup my database outside of the web GUI.


  • Moderator

    @johnomaz said:

    Yes, it can be flagged as solved.

    Good ;)



  • Yes, it can be flagged as solved.


  • Moderator

    @johnomaz said:

    So after deciding to rebuild my FOG server, I decided to go with Fedora 22. CentOS 7 kept giving me issues with downloading certain packages and Fedora gave me zero issues. I got it all back up and running, imported my database and it removed all the hosts that wouldn’t accept a MAC address.

    I do appreciate the help Tom and Wayne gave me (and the extra mile Wayne with). It was a huge help.

    It’s solved ?



  • So after deciding to rebuild my FOG server, I decided to go with Fedora 22. CentOS 7 kept giving me issues with downloading certain packages and Fedora gave me zero issues. I got it all back up and running, imported my database and it removed all the hosts that wouldn’t accept a MAC address.

    I do appreciate the help Tom and Wayne gave me (and the extra mile Wayne with). It was a huge help.



  • I have my images on a seperate internal hard drive and my database is already backed up. Thank you guys.



  • @johnomaz said:

    I unfortunately have to go. I’ll check back tomorrow morning when I get in. I have to image a computer lab in the morning, but after that I may end up rebuilding if a resolution can’t be found.

    We can help you to migrate your images and hosts so that they are not lost - unless you have that under control.



  • I unfortunately have to go. I’ll check back tomorrow morning when I get in. I have to image a computer lab in the morning, but after that I may end up rebuilding if a resolution can’t be found.



  • I do have both directories. The fog directory appears to have all the folders I’ve come to known to be in there (log service snapins utils).

    I’m running CentOS 6.5.



  • What Linux Distro are you using? What version?



  • @johnomaz Um… well… this is a head scratch-er… because - if you completed an installation of FOG, then you should have this file. It’s where all fog installation settings are stored. This is why you are getting the errors right when the installer starts - it’s trying to read settings from that file but because it’s not there, it just throws errors for each line it tries to read.

    Do you have an /opt directory? and /opt/fog directory?



  • @Wayne-Workman cat: /opt/fog/.fogsettings: No such file or directory



  • @johnomaz Can you run this command and give us the output? Obviously omit passwords if you wish to protect them, but not in such a way that destroys the syntax of where/how it was there.

    cat /opt/fog/.fogsettings
    


  • https://i.imgur.com/WxWBJYt.jpg Thats the error I get.

    I do not have a /opt/fog/.fogsettings file. I also didn’t delete said file at any point in time. I know the file exists and unless I have a reason t delete it, i dont’. I haven’t had a reason to delete the file.



  • @johnomaz said:

    @Wayne-Workman I have an issue upgrading. I would upgrade if it wasn’t for the error I get when I try. I get “Sorry, answer not recognized” scrolling for about 8-10 times and then exits.

    Can you get us a screenshot?

    Also - what’s in your /opt/fog/.fogsettings file? Can you post it and omit your passwords (carefully as to not ruin the syntax)?



  • @Wayne-Workman I have an issue upgrading. I would upgrade if it wasn’t for the error I get when I try. I get “Sorry, answer not recognized” scrolling for about 8-10 times and then exits.



  • @johnomaz If you would update FOG, I believe the more recent revisions look for and delete these"0" entries. I think I remember Tom saying that somewhere… it’s been a hot minute.



  • You happen to have a guide on how to do that?

    I have also tried to update my version, but when I run the install script, I get is “Sorry, answer not recognized” scrolling for about 8-10 times and then exits. I do not have a .fogsettings file. I was going to eventually redo my fog server but I haven’t had the time.

    Ok, so doing a bit of googling, I tried delete from hostMAC where hmHostID = 0; and it didnt’ do anything. Is that way off, or in the ballpark? I did a backup of my database before so if I fubar it, I can restore it.


  • Senior Developer

    I’d actually take a look at a more current version of FOG. There were issues that were known about but found after that revision. I’m fairly sure I’ve fixed most of them.

    My guess, right now, is your DB has some hostMAC.hmHostID fields that are setup for a hostID of 0. This is not valid, but because the MAC Exists in this field, but not attached to a proper host, it is causing issues. You will need to take a look at the DB and check that these unassociated fields are removed.



  • Sorry for the seriously delayed reply. Work has been crazy. Its SVN 3261. I’ve used this SVN for months, everything has been just fine for the most part (I’ve had to delete some hosts manually in msyql, but thats about it). I added a bunch of hosts over the past couple of months but I have about 20 that refuse to take a mac address. I’ve deleted the host and recreated it and still doesn’t take the mac address.


 

434
Online

41.5k
Users

12.0k
Topics

113.5k
Posts