HP z series workstations hang after exiting Fog menu



  • I have almost 100 HP z200/210/220/230 workstations that worked just fine under Fog .32. Since building a new server with Fog 1.2 these workstations will all PXE boot to the fog menu without issue. However when it exits the fog menu to continue booting to the hard drive the machines hang. Some hang with “Initializing devices” others seem to look for a SAN and hang there. I found some other threads that sound similar to this and my best guess is I need to change the .kpxe file. Can someone point me in the right direction of which file to get and where to update it on the server? Much thanks in advance!


  • Developer

    check for a bios update and/or use undionly.kkpxe instead of undionly.kpxe (undionly.kkpxe works better with buggy bios/pxe rom configurations)



  • @Junkhacker OK changing the boot exit type solved the problem on my z200/210 trying to boot to SAN. However, I got bad info from my colleague in that the z230 error is prior to the PXE boot menu not after exiting. I have some z230’s that work fine, others hang at the “Intializing devices” message prior to the fog pxe menu. They have the same Intel Boot agent version of 1.4.03 Any ideas why some of these will not PXE boot and others will?



  • @Junkhacker Ahhh, thanks Junkhacker! That should be easy enough. I will first try changing to grub and see what happens


  • Developer

    either renaming the file or changing it in the DHCP scope will work. I recommend changing it in the scope, just so it’s clear exactly what file you’re using the next time you have to look at it.
    the exit type (exit, grub, sanboot) are available choices in FOG Configuration > Fog Settings > FOG Boot Settings > FOG_BOOT_EXIT_TYPE



  • Tom,

    Thank you so much for your very quick response. Please forgive my ignorance but some of the info is not familiar to me. I can figure out how to change .kpxe files, I assume I just grab the .kkpxe rename the old one and copy the kkpxe to the filename undionly.kpxe or do I change the bootfile name in the dhcp scope to the .kkpxe name? But the other info you provided about IPXE statement, grub and exit types is not familiar to me and I’m not sure what to do in that in direction. I am not a linux expert but I have been very comfortable setting up, troubleshooting, changing and customizing whatever I had to do in Linux and fog up through version .32 . I am running Ubuntu 12.04 with fog 1.2 so any details you can provide for this environment to help me get my z series workstation to boot beyond the fog pxe menu is most appreciated.


  • Senior Developer

    I don’t know to implicitly and politely tell people that 1.x.x IS NOT 0.32 and earlier. The mechanisms used to pxe boot only share similarity in the fact that they boot over network. After that, they’re two completely separate beasts.

    It’s exactly these reasons (as described here) that we created the “exit” types for the ipxe menu. Ipxe, for all purposes, is a chainloaded environment, meaning your normal “types” of boot (after pxelinux.0) do not work in the same way.

    For most systems, the IPXE statement sanboot --no-describe 0x80 usually works, but it is not 100%. For this type of boot, I recommend trying the grub or exit types. Grub would probably be the best out of all them for your scenario.

    The kpxe file issue you’re describing seems like what I term “buggy bios” where it hangs at seemingly random points. Please try the undionly.kkpxe file for this. Any systems that work on .kpxe should automatically work with .kkpxe.


Log in to reply
 

358
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.