DNSMASQ setup help



  • i found the issue with i put a wrong symbol in line 11 im going to test it now



  • upload-060cab82-50db-4e14-ac4c-8caca3e0c1a1

    i got this error



  • @mati-92

    In such case - please try this as your ltsp.conf file:

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe,192.168.0.14,192.168.0.14
    dhcp-option=17,/images
    dhcp-option=vendor:PXEClient,6,2b
    dhcp-no-override
    pxe-prompt="Press F8 for boot menu", 3
    pxe-service=X86PC, “Boot from network”, undionly
    pxe-service=X86PC, "Boot from local hard disk", 0
    dhcp-range=192.168.0.14,proxy
    

    Then run this command:

    ln -s /tftpboot/undionly.kpxe /tftpboot/undionly.kpxe.0
    

    Then ensure dnsmasq is running like this:

    sudo service dnsmasq enable
    sudo service dnsmasq restart
    

    See if you can get a status after restarting dnsmasq like this, note any errors:

    sudo service dnsmasq status
    

    For future readers, the last three commands are Ubuntu/Debian specific.



  • i have no idea what the 10.0.0.2 ip addresses are i have had a look in the conf files and i cant see these address in there, could these address be because i am using virtualbox ?i also have no idea what the ub2.pxe my current ip scheme for the entire house is between 192.168.0.1- 192.168.0.255. no pre-existing boot enviroment.



  • @mati-92 And the other IPs? Do you have a pre-existing network-boot environment?



  • my fog servers IP address is 192.168.0.14 and i have made reservations on the DHCP of my router for that address.



  • @mati-92 What is 10.0.2.4 ? what is 10.0.0.2 ? What is ub2.pxe ?

    and

    do you have a static IP set on your FOG server - and a reservation made on your home network device’s DHCP configuration?

    What is your FOG server’s IP?



  • the error i get from the PXE boot is this

    DHCP (net0 08:00:27:6b:7e:bc)… ok
    net0: 10.0.2.15/255.255.255.0 gw 10.0.0.2
    Next server 10.0.2.4
    Filename: ub2.pxe
    tftp://10.0.2.4/ub2.pxe… permission denied
    no more network devices
    FATAL: could not read from the boot medium! system halted



  • screenshot for wayne.png



  • @Wayne-Workman said:

    ls -lahRt /tftpboot

    sorry wayne i am having issues with virtual box i will get the rest of the details now.



  • @mati-92 The first thing that jumps out at me is this line:

    dhcp-boot=pxelinux.0
    

    that should be changed to the boot file you want to use - generally this is undionly.kpxe

    But, I asked for three things and you only provided one. :-)

    Look at the article link you posted, there’s a bit in there about symbolic links. if you wanted to use undionly.kpxe as your boot file, you need to create a symbolic link to undionly.kpxe.0

    also - if you still get further errors after this - we really need to see a photo of the error and we need to know what changes you’ve made - and we need to see the output of the below command.

    Details, details, details.



    this is the file i am using

    # Sample configuration for dnsmasq to function as a proxyDHCP server,
    # enabling LTSP clients to boot when an external, unmodifiable DHCP
    # server is present.
    # The main dnsmasq configuration is in /etc/dnsmasq.conf;
    # the contents of this script are added to the main configuration.
    # You may modify the file to suit your needs.
    
    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Dnsmasq can also function as a TFTP server. You may uninstall
    # tftpd-hpa if you like, and uncomment the next line:
    # enable-tftp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename.
    dhcp-boot=pxelinux.0
    
    # rootpath option, for NFS
    dhcp-option=17,/images
    
    # kill multicast
    dhcp-option=vendor:PXEClient,6,2b
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Press F8 for boot menu", 3
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot from network", pxelinux
    
    # A boot service type of 0 is special, and will abort the
    # net boot procedure and continue booting from local media.
    pxe-service=X86PC, "Boot from local hard disk", 0
    
    # If an integer boot service type, rather than a basename is given, then the
    # PXE client will search for a suitable boot service for that type on the
    # network. This search may be done by multicast or broadcast, or direct to a
    # server if its IP address is provided.
    # pxe-service=x86PC, "Install windows from RIS server", 1
    
    # This range(s) is for the public interface, where dnsmasq functions
    # as a proxy DHCP server providing boot information but no IP leases.
    # Any ip in the subnet will do, so you may just put your server NIC ip here.
    # Since dnsmasq is not providing true DHCP services, you do not want it
    # handing out IP addresses.  Just put your servers IP address for the interface
    # that is connected to the network on which the FOG clients exist.
    # If this setting is incorrect, the dnsmasq may not start, rendering
    # your proxyDHCP ineffective.
    dhcp-range=192.168.1.10,proxy
    
    # This range(s) is for the private network on 2-NIC servers,
    # where dnsmasq functions as a normal DHCP server, providing IP leases.
    # dhcp-range=192.168.0.20,192.168.0.250,8h
    
    # For static client IPs, and only for the private subnets,
    # you may put entries like this:
    # dhcp-host=00:20:e0:3b:13:af,10.160.31.111,client111,infinite
    

    Mod corrected code box.



  • We can help, but we need details to work with.

    Can you provide a copy of your current ltsp.conf file, a screenshot or photo of the error you’re seeing, and the output of this command:

    ls -lahRt /tftpboot
    

Log in to reply
 

274
Online

7.1k
Users

14.3k
Topics

135.1k
Posts