Nfs mount - bad file descriptor / permission denied



  • Hello, I have an NFS share mounted to my fog server, which is Ubuntu 10.04. When i boot a desktop to upload an image i receive the following:

    [QUOTE]mounting file system…mount: 192.168.1.13:/images/dev/ failed, reason given by server: permission denied
    mount: mounting 192.168.1.13:/images/dev on /images failed: bad file descriptor
    fatal error: failed to mount nfs volume[/QUOTE]

    One thing that confuses me is that 192.168.1.13 is my fog server, and my nfs server is a different IP. From within ubuntu i have the nfs share mounted and writable with seemingly no problems. I’ve followed [url]http://fogproject.org/wiki/index.php?title=Image_Upload:_Error_Checking_Mount[/url] to no avail.

    Anyone have any ideas? I’m stuck.



  • I ran into this recently this problem as well with the following error(s) from TFTP boot,

    [QUOTE][I][SIZE=12px]/images/dev on /images failed: bad file descriptor[/SIZE][/I][/QUOTE] and
    [QUOTE][I][SIZE=12px]fatal error: failed to mount nfs volume[/SIZE][/I][/QUOTE]

    The difference in my case was that where the OP had encountered
    [QUOTE][I][SIZE=12px]/images/dev/ failed, reason given by server: permission denied[/SIZE][/I][/QUOTE], I had encountered
    [QUOTE][I][SIZE=12px]/images/dev/ failed, reason given by server: no such file or directory[/SIZE][/I][/QUOTE].

    Why did I run into this? Well, it’s because I was running FOG off of an old converted XP box with limited hard drive space. I had planned the whole platform to a newer box but, well, we know how 'I was planning on getting to it" works. In any event, I had run out of storage space and had moved some of the images off of the current FOG platform’s HDD to an external storage device. In the process, I inadvertently moved the [I]/images/dev[/I] directory. This was the root of the issue.

    TL;DR version:
    Check to make sure you didn’t delete/move your [I]/images/dev directory[/I]



  • I had a similar issue, in a panic I attempted several fixes one them worked, I’ll have to go back and duplicate the problem so I can report back. Here were my steps:

    Firstly edited the config.php in /var/www/fog/commons and reset the tftp password there and in the web gui interface

    Reset the values manually in the aforementioned config file for STORAGE_DATADIR & STORAGE_DATADIR_UPLOAD
    checked the values matching in the web gui as well.

    next umount and re-mounted my storage directly to my default /images on my server (after confirming it worked made it permanent in /etc/fstab).

    checked ‘/etc/exports’ file to see that it matched all my previous configs.
    sudo exportfs -a (if all is well).

    Then I ‘touch’-ed ‘/images’ and ‘/images/dev’ to create .mntcheck

    For testing purposes I chmod -R 777 the whole mount point. Worked

    I’ll try to go back and pin point which part did the trick but I hope this helped.



  • I am having this issue, however I don’t believe that it in the location or a permissions issue. It is a Storage Node that is reporting this error, and that Storage Node also gives a message about its RAID being degraded at boot.

    Can this message (NFS Mount/Bad File Descriptor) be caused by the degraded RAID?

    If I choose to start the degraded raid it mounts fine and I can browse the contents.

    Edit: I have since fixed the issue, but not figured out what caused it. We just ended up backup up and starting from scratch, which has definitely had its benefits, we are seeing much better speeds now!



  • Thanks, I did not see that page. Useful info. However, I followed a different path, and managed to mount the new partition already. But I never knew that the problems were caused by NFS until I stumbled on this topic when searching. I have no clue diagnosing NFS connections, but searching on yesterday I found the solution closer than I thought :) :

    [url]http://www.fogproject.org/wiki/index.php?title=Change_NFS_location[/url]
    and:
    [url]http://fogproject.org/wiki/index.php?title=Images_Directory_Permissions[/url]

    After this the diskspace indicator on the dashboard also gives the correct size.

    I really wonder why these steps are not automated when entering a new image store path into the webinterface,
    perhaps nice for v.033 ;)



  • You all should read this in regards to adding storage space to Fog.

    [url]http://fogproject.org/wiki/index.php?title=Adding_Storage_to_a_FOG_Server[/url]

    Please note the sudo touch command, this should fix the permissions issue with given folder.



  • ok this might not even be closely related to your issue, but it is saying permission denied ? does the FOG account have permission to both those folders ? /images/dev and /images ?



  • Same problem here. FOG 0.32. Moved Images folder to /data, a mount to another partition.
    Followed link above to check/fix.
    Stuck as well …



  • I am also receiving this same error. I am trying to move the location to a Lacie 5big NAS.



  • Did you ever figure this out? I have the same issue. I too followed the fog wiki you posted above. What is supposed to be in the .mntcheck files? Mine have nothing in them - 0kb.


Log in to reply
 

367
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.