FOG with proxyDHCP - Bootloop



  • Hi!

    After installing FOG successfully, I am now configuring the ability to boot FOG via iPXE.

    I’m using VMware Workstation at this moment, without any DHCP Server.
    (Using VMware DHCP Settings)

    In order to boot FOG via iPXE, I must configure an proxyDHCP. I’m following the tutorial available in the wiki, alongside with other info that I found.

    The solution architecture:
    arq.png

    I installed dnsmasq, created the symlink for the undionly.kpxe file, but now I’m facing boot loop.

    My dnsmasq.conf file:

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe,fog,192.168.56.128
    dhcp-option=17,/images
    dhcp-option=vendor:PXEClient,6,2b
    dhcp-no-override
    pxe-service=X86PC, "Booting into FOG!", undionly
    dhcp-range=192.168.56.128,proxy
    

    The Bootloop: https://www.youtube.com/watch?v=XP1mWH6Sw_8

    Can someone help me?
    Thanks!


  • Senior Developer

    @rvieira said:

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kpxe,fog,192.168.56.128
    dhcp-option=17,/images
    dhcp-option=vendor:PXEClient,6,2b
    dhcp-no-override
    pxe-service=X86PC, “Booting into FOG!”, undionly
    dhcp-range=192.168.56.128,proxy

    Try this for your configuration:

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kkpxe,fog,192.168,56.128
    dhcp-option=17,/images
    dhcp-options=vendor:PXEClient,6,2b
    dhcp-no-override
    pxe-service=X86PC,"Booting into FOG",undionly.kkpxe
    dhcp-range=192.168.56.128,proxy
    

    Then link the undionly.kkpxe as suggested earlier.
    ln -s /tftpboot/undionly.kkpxe /tftpboot/undionly.kkpxe.0


  • Senior Developer

    The problem is the link but not as you’d expect. You have your boot file set to look for undionly.kkpxe so the first file its looking for is appended as undionly.kkpxe.0. I’d say try creating a link asln -s /tftpboot/undionly.kkpxe /tftpboot/undionly.kkpxe.0


  • Moderator

    @rvieira Oh duh, I see the issue now.

    You need to specify the symbolic link in your dnsmasq config.

    We sym-link undionly.kkpxe to undionly.0 because giving the value of undionly.kkpxe doesn’t work with dnsmasq, it truncates the extension and replaces it with a “0”… it’s weird, and I don’t know why. So you need to specify undionly.0

    Hopefully I explained that clearly, I’m in a bit of a rush.



  • @Wayne-Workman still happens the same.

    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.kkpxe,fog,192.168.56.128
    dhcp-option=17,/images
    dhcp-option=vendor:PXEClient,6,2b
    dhcp-no-override
    pxe-service=X86PC, "Booting into FOG!", undionly
    dhcp-range=192.168.56.128,proxy
    
    [root@fog tftpboot]# ls -lisa
    total 2572
    3014657   4 drwxr-xr-x   2 fog  root   4096 Aug  3 17:45 .
          2   4 dr-xr-xr-x. 24 root root   4096 Aug  3 15:51 ..
    3014658   4 -rw-r--r--   1 fog  root    840 Jul 31 21:54 boot.txt
    3014671   4 -rw-r--r--   1 root root    296 Jul 31 21:54 default.ipxe
    3014659 380 -rw-r--r--   1 fog  root 389009 Jul 31 21:54 ipxe.kkpxe
    3014660 380 -rw-r--r--   1 fog  root 389057 Jul 31 21:54 ipxe.kpxe
    3014661 380 -rw-r--r--   1 fog  root 388044 Jul 31 21:54 ipxe.krn
    3014662 380 -rw-r--r--   1 fog  root 389073 Jul 31 21:54 ipxe.pxe
    3014663  28 -rw-r--r--   1 fog  root  25340 Jul 31 21:54 memdisk
    3014664  20 -rw-r--r--   1 fog  root  16794 Jul 31 21:54 pxelinux.0.old
    3014665 164 -rw-r--r--   1 fog  root 165088 Jul 31 21:54 snponly.efi
    3014672   0 lrwxrwxrwx   1 root root     14 Aug  3 17:45 undionly.0 -> undionly.kkpxe
    3014666 100 -rw-r--r--   1 fog  root 101989 Jul 31 21:54 undionly.kkpxe
    3014667 100 -rw-r--r--   1 fog  root 102037 Jul 31 21:54 undionly.kpxe
    3014668 376 -rw-r--r--   1 fog  root 382650 Jul 31 21:54 undionly.kpxe.INTEL
    3014669 100 -rw-r--r--   1 fog  root 102053 Jul 31 21:54 undionly.pxe
    3014670 148 -rw-r--r--   1 fog  root 147728 Jul 31 21:54 vesamenu.c32
    

  • Moderator

    It appears that you have ProxyDHCP setup corectly, I think the actual boot file is the problem.

    Instead of using undionly.kpxe, try to use undionly.kkpxe

    I know the names are confusing… but there IS a difference lol. .kkpxe works with anything that .kpxe works with and additionally works with the more buggy/crappy BIOS firmware out there.


Log in to reply
 

409
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.