No operating system error message after wiping HD and trying to image



  • Hello, we are using FOG ver 1.2.0

    I’m wiping off the image on our 2go pc’s Model E12. The wipe is completed and then I go to deploy the image and I’m getting a black screen with the message “no operating system” … I’ve done several things to try and fix this …
    I formatted the HD and manually installed the OS (wind 7) then tried to deploy image again … no luck
    I’ve tried to deploy a different image … no luck
    I’ve gone though all the repair options on the Wind 7 install … no luck
    I’ve tried to re wipe the HD using all options of wipe and then redeploying … no luck

    Assuming my only options is to format HD and reload OS run all windows updates and try again?? Just wondering if anyone has had this problem before? We have 100 of these to do so hoping to find a fix!!

    Thank you in advance for your help!!



  • GREAT NEWS!! The re sizable image is working!! Thank you everyone for your help, and although it seems like I should of thought of that, I appreciate your time and patience with me!!
    Your guys are the BEST and we LOVE your program! Thanks for sharing!
    Have a great day!!



  • Had a bump in the road! User error! LOL

    Still uploading new “re sizable” image etc … stay tuned I’ll update tomorrow!

    Have a great night!



  • @Tom-Elliott
    Yes Tom the HD from the source is larger then the target device. I’m uploading a “re sizable” image now and will try that! Thank you!!
    Stay tuned!! :)



  • Thank you all for your responses … let me look at all this things and try the suggestions! I will for sure report back!
    I really appreciate your help!!
    Happy Tuesday! :)



  • Sounds like it could be a missing AHCI or SATA raid driver in the image. Try switching the drive to “IDE” mode in the bios.


  • Senior Developer

    Have you made sure this image has an appropriate operating system assigned to it?

    Forget the above.

    Is the harddrive the original image came from larger than the hard drive the image is trying to go on to?



  • @sandy.rolandson Is the image type “resizeable” ?


  • Testers

    What OS is your fog server running on? You can also try the script in this thread https://forums.fogproject.org/topic/4581/let-s-make-scripts



  • I think I know what the issue is. Try shrinking the partition/volume on the computer that is used for creating the image before uploading. That way the partition that is restored is will be a few GBs less than what the computer you are trying to image to. I noticed when I was trying to image to identical computers the claimed to have the same hard drive space as the computer that the image was made on I had the same issue you had in the video. The computer doesn’t actually image FOG seems to just bail out and then the computer reboots.

    Edit: An easier way to test this would be to throw in a hard drive that you for sure know is larger (not the same) than the hard that the image came from and then try imaging. Or even just use a different computer with a larger hard drive to test if the imaging process starts (even if the image isn’t built for that computer you can still do it just to test).



  • Ok here is the video!
    Thank you so much for your help!!

    https://youtu.be/O46lQkDDXdc



  • Ok I’ll try to do that now with my phone! :) Stay tuned!



  • @sandy.rolandson said:

    “then runs all the Checks and boom”

    Please elaborate on that part (what kind of boom? was it loud? lol). You can take a short video of the imaging process and upload to YouTube, and then paste the link here? If you can, a video from boot to the reboot would be best.



  • When trying to search the wiki and knowledge base for apache , I click on link and it just takes me back to the manual index page … if you can help please do!
    Thank you!



  • Hello, I did do a search on how to get to these error files and no luck … :( I’ll keep plugging along …



  • Heading to lunch will check back with you when I get back!
    Thank you for your help!! :)



  • We have not had to do this before can you provide instructions on where/how to check the apache error logs?



  • @Wayne-Workman said:

    have you checked your apache error logs?

    Here is what I get … when trying to image device …

    It boots off the LAN fine
    Goes into FOG checks good
    Config …ok
    FOG boot … ok
    BzImag …Ok
    init.xz … ok
    Flashing cursor for awhile
    then runs all the Checks and boom goes back into the window boot and come back with Missing operating system

    We are checking into checking the apache erro logs! Thanks!



  • @sandy.rolandson Ok so what happens during the image process? Does it image all the partitions to the host correctly? Are there any errors during any point of the imaging process? have you checked your apache error logs?



  • I went into Disk Management to see if MBR or BPT … we are assuming it is MBR? Hope that helps!


 

579
Online

5.4k
Users

12.6k
Topics

118.8k
Posts