Multicast session not becoming a task



  • Hello all; new to FOG ( 2 weeks of using it so far) and having an issue with multicast.
    Background:
    Virtualbox install
    Ubuntu 14.04
    Fog running 4238 from Github.
    I run the tests listed in troubleshooting muticast and things seem ok there.

    When i log on to the portal I go into image management, multicast image. I add the name, client count, timeout, and select the image. When I click to start the session I get the following response: "Multicast session created ((session name)) has been started on port ((port number that changes each time I do it)).

    There is no task listed anywhere on the portal and if I pxe boot a client and attempt to join a session the one I created is not active.

    I have shutdown the vm and started it, restarted FOGMulticastmanager service.

    Any thoughts?



  • Awesome. I will be back onsite tomorrow.

    You folks are awesome.


  • Moderator

    @Tom-Elliott said:

    For example, if a Host gets created, but somehow has an ID of 0, it will be removed automatically.

    I’ve been meaning to request this exact thing as a feature. This is very much so needed and a major improvement.

    I was going to suggest having the installer do it, or the troubleshooting script do it, but this is even better because the user will never even know there was a problem, or that it was fixed. It’s beautiful.


  • Senior Developer

    @Elkon 4240 should fix the creation issue.

    The problem, just so all are aware, is I have added cleanup code to remove entries that aren’t assigned properly. For example, if a Host gets created, but somehow has an ID of 0, it will be removed automatically.

    For this particular issue, it was checking if the Storage Group ID was set. If not, it would remove the entry. So when checking, it was not creating the tasking with an NFSGroupID set, and therefor it would create the entry, but immediately remove it.


  • Senior Developer

    Funny I noticed the exact same thing and am trying to fix it. I have to get home first. It will likely be about 2 hours or so from the time I’m posting this.


Log in to reply
 

353
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.