Muticast broken on git 4196 for servers with multiple nics



  • I am running git version 4196 of fog on a red hat release 6.6 system. I can no longer multicast - it just hangs on the clients waiting for the multicast to start. The multicast.log file shows that the multicast server is picking up eth1 instead of eth0 for the multicast interface (both are active). The FOG_UDPCAST_INTERFACE is set to eth0. Is there someplace else to look?



  • Correct.


  • Senior Developer

    According to one of the other posts this is solved as of, i think, 4250.



  • This has not been solved.



  • That did not work (I have even rebooted since this started). It acts like it is no longer using that interface value, but getting a list of NICs from the system and using one of those.


  • Senior Developer

    It will only use the FOG_UDPCAST_INTERFACE setting if it fails to find a suitable storage node.

    The fact that it’s not using the proper interface tells me you likely need to restart the FOGMulticastManager service with sudo service FOGMulticastManager stop; sudo service FOGMulticastManager start



  • The Interface is set to eth0 there also. So it is not using that value now.


  • Senior Developer

    FOG_UDPCAST_INTERFACE is no longer used. I forget which revision changed this specifically. This is because ultimately Multicast is handled by the Master nodes on the server(s).

    Check your Storage Node (Master) and set the interface setting there. This should correct the issue you’re seeing.


Log in to reply
 

432
Online

38955
Users

10706
Topics

101578
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.