Fog FTP login fails after image creation.



  • Fog FTP login fails after image creation, complains the ftp userid and password are not correct. Image creation is showing the user name and password which is the fog user id and password and the user id and password under storage management and tftp server.

    I am using Centos 6.5 Fog 1.2.0. Passwords have all been confirmed. Ftp is working with the fog and fog created password from a windows client, can create, copy to and read from ftp:\images folder. Folder access rights look correct and seem to be working.

    Something is not working after the image successfully creates. Also after the failure under image management I see the image but get a fogftp:login failed username fog Password (system generated password). Error also happens when I try to delete the created image from the image management screen. Image will not delete.

    I have logged into Centos with the fog id and password from the tftp and storage screens which are the same in the web page, and I am able to go into the /images directory and erase the image folder with no issues. There must be a password which is not correct somewhere, but I can not find it. I went though the wilki on this and am still having a problem. Both firewall and seliunux are disabled. FTP from windows works, and I can get into the /images directory and erase the 99.5% complete image. I can not delete the image from the web page though with out getting the ftp log on error?

    I originally posted this under another users problem by mistake, but I have moved it out to the root. Thanks for any help you can give.



  • Everyone this was my problem. You have to take the user and password from the fog storage nodes under the fog system settings and put them into a hidden file in the opt/fog directory .fogsettings config file. After I did this the image created successfully without complaining about the ftp password. I will now try to drop the new image onto a new computer and see how I make out, but I think this will do it for me. Wow I have struggled with this for two weeks now. I like the concept of the fog imaging server and will now be able to really test it out.

    Like everything else in life if you don’t struggle with it you will never learn anything. I learned a lot about linux by setting this up.

    Thanks again.



  • /opt/fog/.fogsettings -> storageftpuser & storageftppass

    I did not realize the .fogsettings file was invisible. Once I figured out how to see the invisible file I found the

    snmysqluser=" “
    snmysqlpass=” "

    In the web page there are values for this which are automatically generated. I put these user and password values in and now I am able to erase the image from the web page. I am in the process of creating a new image now to see if this was the missing piece. Thanks for your help with this. I will post back if this works.


  • Moderator

    @JoeCT Please look here and see if you can get it sorted out. Let us know if you need further help. https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Credentials_.2F_Passwords


Log in to reply
 

430
Online

39.3k
Users

11.0k
Topics

104.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.