UNSOLVED Unable to download image with FOG trunk 3764

  • I’ve not had any success since moving away from 1.2.0 so I feel like I’m missing something.

    I created a new image, type 4 (raw dd) and set partition to “everything” with compression set to 1 hoping it’d not store the 300 some odd gigs of 0’s that way.

    I then assigned the image to my source machine and scheduled an upload task. Booting the source machine to the network brought me to the clone process, which took about two hours. (Expected for a dd)

    Then I assigned my target host that same source, and scheduled a download task (in debug mode, because I expected it not to work). Booted the target machine to the network and it started fine. Started the fog process and went through it at each step.

    Variable dump:

    typed in ‘fog’ enter
    attempting to send inventory, done
    checking in, done
    mounting filesystem, done
    checking filesystem, done

    starting image push
    using image Source4
    looking for hard disks, done

    wiping /dev/sda partition info
    erasing mbr/gpt, done

    creating disk with new label, done
    initializing /dev/sda with ntfs, done

    processing partition /dev/sda ()
    partition file missing /images/Source4/d1p.img
    stopping fog status reporter, done
    changing hostname, done

    database updated
    task completed

    So, it would appear it can’t find the image file…?

    I went on the server and looked in /imgages/Source4, there’s only one file- Source4 with a size of 187GB

  • @netman86 said:

    Running through debug it said something about the partition table in the image being no good.

    What’s the exact error? Can you get a screen shot?

  • With the extended partition, when I go to restore, it simply fails. Running through debug it said something about the partition table in the image being no good.

    With no extended partition, it worked a treat- that’s what I used today. It re-sized the partitions a bit funny, but I got over it.

  • @netman86 What happens when you do single disk resizeable?

  • I love when it’s just one after another…

    these machines have to be on a plane Monday so I just did the unthinkable and multicasted them without the extended partitions (multicast worked like a charm!) and then went to each one and created the partitions and added the data. Yuck!
    It’s done, anyway.

    Onto the next project…

  • @netman86 yeah… it was one problem, I side stepped that, and then another problem lol.

  • @Wayne-Workman That appears to be a dhcp issue- what I’m seeing is something along the lines of the thing booting network just fine, but it finds the partition table to be corrupt if there’s an extended partition, and refuses to download the image.

  • @netman86 Well now we know exactly where and what your problem is.

    For the record, I’m stuck with the same issue I believe: https://forums.fogproject.org/topic/5417/dell-optiplex-9020-uefi-network-booting

  • I built a base win7 and imaged it- worked fine. Ran all the updates and imaged it, worked fine.

    Created my D partition, worked fine.

    As soon as I created an extended partition, the download failed- even though the upload still runs flawlessly.

    I suspect that it’s related to SDA4 (the extended partition that SDA5 exists inside of) touching the end of the disk. I’ve seen odd problems with images in the past where shrinking a partition by just a few megs would make a difference.
    Of course, windows won’t let me do that…

  • Can you please please please make just a regular scratch image very quickly, upload and download, and see if it works or not?

    What I’m asking is… Just install Win 7 (or whatever you’re using) and THAT’S IT!!! No updates, no software, no nothing, no nothing, not even drivers, no nothing except for the operating system. This should be very fast.

    Please do this, and then upload, and then download back to another machine of the same model and just see if it works. Use single disk resizeable.

    This will tell us if your problem is specific to your image, or to something else.