Network Blocking FOG



  • I tested fog on a simple un-managed switch. works super quick. I moved it to the primary network to put in production. Now it errors out on mounting NFS. I read that there is a few issues with STP (ugggh). We do have a IPS , but already made a policy for the fog to allow all. So my question is what else could possibly not make it work. We have Brocade switches(pretty much Cisco IOS) Fog has normal network connectivity. I can upload SOME of the switch configs but not all if it will help.


  • Moderator

    @brycew Can you please try manually mounting via the steps here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_NFS

    Perhaps something happened to your fog server when you rebooted… It’s the only thing I can think of.

    For testing the NFS mounting manually, try the easy way first. If that fails, try the long way next and see what happens.

    If those tests succeed while the FOG server is connected to your production network, then the network is not the issue, there’s something up with FOG in this case.

    If those tests fail while the FOG server is connected to your production network, this could mean several things…

    1. Move FOG back to an unmanaged switch and re-run the tests… if they fail, something happened to the FOG server during reboot.
    2. Move FOG back to an unmanaged switch and re-run the tests… if they SUCCEED, then it’s your network, guaranteed.


  • nice catch @Wayne-Workman. UFW was running but did not fix the issue. it is now disabled. Ubuntu 14.04


  • Moderator

    Why not check basic things like firewall and SELinux ?

    If you merely stopped the firewall and didn’t disable it, then it’d turn back on when you rebooted to move the server.

    And you haven’t told us what version of linux you’re using either.



  • Hmm i might just disable STP on that port. Have to move it out of a switch. @Tom Elliott im currently running trunk 3731.


  • Senior Developer

    On the development/trunk versions of fog, iPXE has added some potential fixes to the never ending STP issue that was. Supposedly this should fix the STP problem, but I don’t know until people test.

    I’m sure I’ve screwed up enough on what we have right now, but it should be at least kind of operational. I can’t fix what I don’t know about either.



  • The ONLY issue I’ve ever had was with Spanning Tree. I enabled Rapid Spanning Tree Protocol, and the issue went away.

    I ended up actually disabling STP on the ports used by fog. I really would just disable STP on those affected ports and see if that fixes it. I bet it does.


Log in to reply
 

469
Online

38923
Users

10690
Topics

101416
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.