• I have setup FOG on a Ubuntu Server with a static IP that runs as VM on my ESXI server.
    My DHCP is controlled by the router provided by my ISP and doesn’t have Option 66 & 67 settings.
    I’ve made a second VM on my ESXI server to test PXE booting.

    The problem I encounter is that my client does PXE boot but doesn’t receive an IP.
    Could not having Options 66 & 67 on my DHCP be the cause? Or should my DHCP router always assign an IP to the client?

  • @bitloader You can run DHCP on a 40 dollar Raspberry Pi… It will never fail lol, all solid state… it uses like 5 volts, connect it to a small battery backup and in a power loss, it will run for 2 weeks lol.

  • @Wayne-Workman Thanks for the advise on ProxyDHCP. I reinstalled FOG following the guide and now my client gets a correct IP.

    As for Linux doing a better job at managing DHCP…yes, you’re probably right and it’s something I’ve been considering. However, since there is always a chance that my ESXI would fail and kill the few VM’s running on it. It would stop my mobile devices from getting an IP and connecting to the internet…And in my home, not having internet will upset the wife terribly.

    Thanks again for the ProxyDHCP pointer. I think I’m all setup now to start imaging my first VM test client. And if all goes well, the next step will be my laptop.

  • @bitloader Additionally, you could turn off DHCP on the device that your ISP gave you, and just let FOG handle DHCP… then you wouldn’t need to mess with ProxyDHCP… and Linux will probably do a much better job at managing DHCP anyways.

  • @bitloader Not only do you need to specify options 066 and 067, your clients should also always get an IP from DHCP.

    Sounds like you need to mess with ProxyDHCP. This is for people in your boat, either no permission to change DHCP, or have a device that doesn’t support the needed options. Check out this WiKi article and let us know if you need any help. https://wiki.fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server