Image won't deploy to systems already imaged



  • Hey Gents!

    I’m seeing an issue here where after imaging, I can’t deploy an image to that machine. Here is the sequence I take to re-image:

    FOG >> Host Management >> List all hosts >> select host >> basic tasks >> Download >> Create download task for host <host>

    fogsnip.PNG

    It seems on the older version of FOG, you wouldn’t have to upload the image to deploy, you could just deploy the image after having imaged it once. Am I correct in this thinking? Am I going about this the right way?

    Let me know what to look at, thanks all!


  • Senior Developer

    @sarge_212 What version?



  • Hey all,

    I think this is a bug.

    If I go to Task Management > List all hosts > click the Download arrow for that host, it downloads an image. However, if I go to host management > select the host > basic tasks > download > schedule the download, I get the error about optimal storage node. Just wanted to let you know after much hair pulling. Thanks.



  • No problem Wayne. This forum is awesome and you guys are all way responsive and helpful. Thanks!



  • @sarge_212 I will continue to offer my assistance with your issue, But at this point, I’m just being honest when I say that it may be faster to rebuild the FOG server. And, in most cases, it’s not a big deal either. I can build a FOG server in under 3 hours by myself and most of that is twiddling my thumbs waiting on installation and OS updates. Add another hour or two for transferring your images - mostly thumb twiddling.

    Also, you might want to reach out to someone like @cml or @Tom-Elliott or @ch3i for assistance. Because what I would suggest at this point is trying to delete and recreate the fog user but you’ve already done that… and I’m not totally sure where to go from here.



  • I am attempting to do that, but I keep getting a (current password) prompt. After entering in all sorts and variations of passwords, I get authentication failure. I’ve tried userdel -uf fog to force remove the fog user and then add it again. It just doesn’t seem to be working. Also, I noticed in /var/www/html/fog/lib/fog/Config.class.php, that the STORAGE_FTP_PASSWORD wasn’t in this file. I added it there but still getting the error about Undefined index, optimal storage node.



  • @sarge_212 Strange… can you just manually create a user called fog and assign it the correct password, the one inside /opt/fog/.fogsettings and the other areas?



  • Wayne,

    Should users be created in /etc/shadow and /etc/passwd that are fog UI users? Just curious because none of those users I have created are in those files. I checked the log for vsftpd and it mentions that the user is unknown. I’m pretty sure it’s something in the environment where the user isn’t being recognized. Thoughts?



  • @sarge_212 Never seen that one before… But it’s still related to FTP.

    Go through the credentials part of that article I posted again… see if that clears it up.

    Also try some of the test statements at the beginning of that article, just to verify if FTP is working or not with the credentials you set.



  • Further, I guess, now I get this:

    fogsnip2.PNG

    I’m not using a NAS or anything, just another partition, /images where I’m storing the image. We’re only using one or two images in our environment.



  • AHHH!!! there is no password there…let me throw one in and see what happens. That’s probably it. I somehow neglected to get to this menu before. ./headslap



  • @sarge_212 very weird indeed…

    What user do you have set inside Storage Management -> Your storage node -> credentials.



  • Weird,

    I tried changing the password for fog in ssh and I keep getting authentication failures. So I check /etc/passwd and /etc/shadow and there is no fog in either of those. ???


  • Senior Developer

    Sign in with another user with sudo permissions.

    Once signed into the terminal/console gain root, typically with: sudo -i.
    You can reset the FOG user password with: passwd fog.



  • Wayne,

    I looked at all of those, and I tried to change the FOG password on the Linux server. However, I don’t know the current password so I get locked out of changing the FOG user’s password. Any quick way around that?



  • I think that you are suffering from a common FTP credentials issue.

    Here is the guide on how to solve it:

    https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Credentials_.2F_Passwords


 

317
Online

41.6k
Users

12.1k
Topics

114.4k
Posts