Fog and Uploading VMWare VM Image

  • Can I upload a VMWare VM as an image? When it boots, FOG loads but then I get an error: Unable to locate hard disk

    Is there a way to make this work? I’m trying to create a generic Windows 7 image for deployment.


  • Yeah, I’ve technically got my kernel edited to include the SCSI drivers, but I agree - it would’ve been easier to just switch to IDE before loading the OS.

  • Moderator

    If you leave the drive type as SCSI, it will not find the hard drive when loading the kernel. You can customize the kernel to include the vmware pvscsi driver but you have to build a custom kernel. Easier just to change the drive type to IDE before loading the OS.

  • Got Single Partition (resizable) working for my new image.

    The important difference between the two images: The new image was created [I]without[/I] using VMWare’s “Easy Install”. I ran through the Windows installation by hand, manually removed all the partitions, and allowed Windows to create that extra 100 MB partition. With that in place, FOG recognizes and handles Windows 7 as a single, resizable partition.

    I also created the VM, deleted the SCSI drive, and added in an IDE drive before installing Windows on it, but I don’t think that has anything to do with this issue.

  • Yeah, I’m just puzzled as to why the Single Partition works for the one with that extra boot partition, but not for the one that has the boot partition removed. I would expect it not to work for either in this situation.

    But hey! It’s working. And that’s what I really care about, haha.

  • [quote=“dvlsg, post: 5167, member: 1186”]Got it working as a Multi-Partition Single disk. It’s interesting that a Single Partition upload works for a VM with two partitions, but only a Multi Partition upload works for a VM with one partition.[/quote]

    well it is not realy one partition as windows 7 has boot partition of 100Mb and it is counted as partition so you have a 2 partition image.
    i usually get rid of the boot partition when building windows 7 images from scratch to make it easy when using cloning systems like fog.

  • Got it working as a Multi-Partition Single disk. It’s interesting that a Single Partition upload works for a VM with two partitions, but only a Multi Partition upload works for a VM with one partition.

  • I may have to do that.

    I ran into another snag though (which is probably the actual problem) - With my original VM, it would properly recognize NTFS, and would upload as single partition, resizable. With my new VM, it doesn’t properly recognize NTFS, has a fit, and then tries to upload as RAW.

    The two main differences I can find is that the working VM is IDE and has the 100mb partition in place. The one that is not working is SCSI and has only one partition.

    Still trying to run down a solution. Not having much luck.

  • i dont know about vmware player as i have vmware workstation but i use gparted ISO to boot from then shrink the disk. i used it once with a windows 7 image to reduse the size from 79 Gig to 38.

  • I have a question for those of you using VMware to upload images.

    I have VM that I converted from a deployed Ghost image, which automatically pulled in to IDE, but the size is just awful (78.3GB allocated for the VM). However, FOG will only grab what’s actually being used by the VM, and leave behind the white space.

    When creating a new VMware image, I had to go with SCSI, as I only had VMware player available to me. I got the 3.5 kernel recompiled with the VMware SCSI driver so it loads properly, but it looks like FOG is trying to grab the entire partition (40.0GB) instead of only the used space (24.4GB).

    Does anyone know a good way to work around this?

  • Not too sure what this does, but by me switching the SCSI Controller Type to VMware ParaVirtual worked for me.

    Right Click your desired VM < Edit Settings < Hardware tab < SCSI controller 0 < Change Type < Select VMware ParaVirtual

  • i have 8.0.1 and as i said it works after updating the kernel.

  • I have VMware Workstation 6.X and I’m able to upload an image just fine using Fog. What version of Workstation are you running?

  • Hi mate
    sorry for not responding fast as there are no mail notification here. i was going through the latest and found this. any way i would gladly upload my bzImage some where if you cant get it working and put a link on the forum.

  • I am not able to set the hard drive to IDE. The only options are scsi. I will attempt adding iscsi support. Thank you for the response.

  • Moderator

    can you set the Hard Drive to IDE?

    or see below to add iscsi support to the FOG boot kernel

    [quote=“Ahmed, post: 1619, member: 113”]Hi
    I downloaded the latest kernel 3.2. used this link to build a custom kernel
    enbled SCSI low-level drivers from the left side and VMware PCSCSI drivers support from the right side.
    built the new kernel and it worked like charm
    just to note that this command does not work anymore “[FONT=Courier New]make bzImage”. just writing make will fix the bzImage in case you need to update the wiki[/FONT][/quote]