Lenovo L530 - dnsmasq issues


  • Moderator

    This is an interesting problem.

    At work, I use undionly.kkpxe as my bootfile and this is handed out via DHCP. Works fine with the Lenovo L530.

    At home, I use dnsmasq and undionly.kkpxe

    I tried to network boot my Lenovo L530 at home and it gets the undionly.0 (copy of undionly.kkpxe) and acts like it’s going to boot, but then says:
    PXE-M0F Can’t find default.ipxe (or something like that).

    This isn’t really important but I thought I’d say something.


  • Moderator

    And I’m using r3710 at home, and r3709 at work… couldn’t be that much of a difference lol.


  • Moderator

    Here’s a video of it:

    https://youtu.be/0_LOrzdDSVY

    Like I said, confirmed that other equipment is fine with the setup at home… I’m using undionly.kkpxe both at work and home, laptop works at work but not at home.

    I’m thinking that this model just doesn’t like how dnsmasq does it’s job… it is very hack-ish, you know.


  • Moderator

    Here’s what’s in /tftpboot, notice that undionly.0 and undionly.kkpxe are the same size, they are copies. I’ve never been able to get a symbolic link to work with dnsmasq.

    [root@fog /]# ls -laht /tftpboot
    total 4.0M
    drwxr-xr-x   4 fog  root 4.0K Jul  8 17:19 .
    -rw-r--r--   1 root root  87K Jul  8 17:19 undionly.0
    -rw-r--r--   1 root root  396 Jul  6 16:48 default.ipxe
    -rw-r--r--   1 fog  root  87K Jul  6 16:48 undionly.kkpxe
    -rw-r--r--   1 fog  root  87K Jul  6 16:48 undionly.kpxe
    -rw-r--r--   1 fog  root  87K Jul  6 16:48 undionly.pxe
    -rw-r--r--   1 fog  root  30K Jul  6 16:48 vesamenu.c32
    -rw-r--r--   1 fog  root 168K Jul  6 16:48 snp.efi
    -rw-r--r--   1 fog  root 168K Jul  6 16:48 snponly.efi
    -rw-r--r--   1 fog  root  88K Jul  6 16:48 realtek.kpxe
    -rw-r--r--   1 fog  root  88K Jul  6 16:48 realtek.pxe
    -rw-r--r--   1 fog  root 168K Jul  6 16:48 realtek.efi
    -rw-r--r--   1 fog  root  88K Jul  6 16:48 realtek.kkpxe
    -rw-r--r--   1 fog  root 121K Jul  6 16:48 ldlinux.c32
    -rw-r--r--   1 fog  root  26K Jul  6 16:48 memdisk
    -rw-r--r--   1 fog  root  29K Jul  6 16:48 menu.c32
    -rw-r--r--   1 fog  root  43K Jul  6 16:48 pxelinux.0
    -rw-r--r--   1 fog  root  43K Jul  6 16:48 pxelinux.0.old
    drwxr-xr-x   2 fog  root 4.0K Jul  6 16:48 pxelinux.cfg
    -rw-r--r--   1 fog  root 320K Jul  6 16:48 ipxe.pxe
    -rw-r--r--   1 fog  root 319K Jul  6 16:48 ipxe.krn
    -rw-r--r--   1 fog  root 320K Jul  6 16:48 ipxe.kkpxe
    -rw-r--r--   1 fog  root 320K Jul  6 16:48 ipxe.kpxe
    -rw-r--r--   1 fog  root 874K Jul  6 16:48 ipxe.efi
    -rw-r--r--   1 fog  root  88K Jul  6 16:48 intel.pxe
    -rw-r--r--   1 fog  root 169K Jul  6 16:48 intel.efi
    -rw-r--r--   1 fog  root  87K Jul  6 16:48 intel.kkpxe
    -rw-r--r--   1 fog  root  88K Jul  6 16:48 intel.kpxe
    drwxr-xr-x   2 fog  root 4.0K Jul  6 16:48 i386-efi
    -rw-r--r--   1 fog  root  840 Jul  6 16:48 boot.txt
    dr-xr-xr-x. 22 root root 4.0K Jul  6 16:48 ..
    

    Contents of /etc/dnsmasq.d/ltps.conf this configuration has worked for me for half a year without issue, and works for other devices on the network currently.

    [root@fog /]# cat /etc/dnsmasq.d/ltsp.conf
    port=0
    log-dhcp
    tftp-root=/tftpboot
    dhcp-boot=undionly.0,10.0.0.3,10.0.0.3
    dhcp-option=17,/images
    dhcp-option=vendor:PXEClient,6,2b
    dhcp-no-override
    pxe-prompt="Press F8 for boot menu", 3
    pxe-service=X86PC, “Boot from network”, undionly
    pxe-service=X86PC, "Boot from local hard disk", 0
    dhcp-range=10.0.0.3,proxy
    

  • Moderator

    @Tom-Elliott undionly.0

    It appears to find that just fine and load it. Some FOG specific stuff shows on the screen, then it says it can’t find default.ipxe

    A side note is network booting works fine for other equipment in the house.


  • Senior Developer

    Is it finding undionly.kkpxe.0 or undionly.0?


Log in to reply
 

403
Online

38955
Users

10706
Topics

101576
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.