Fog .32 and Capeone



  • Does Capone work with Fog .32?
    I enabled the capone pluging , activated it, accossiated an image and DMI , copied the configuration text to PXEBoot menue and then saved it, but when I reboot the client machine, I can’t see no Capeone in PXE menue.
    any one has ever faced this?

    Thanks



  • Thanks for the info, I’ll try and let you know.



  • [quote=“sid, post: 2583, member: 558”]I made up a password and typed it in as Master Password and the Capone showed up, but nothing happens when I select the capone in Pxe menu.
    I assocciated the System Product Name to the Capone, but it won’t do anything in PXE menu.
    any Idea?
    Thanks[/quote]

    Sid,

    I think I have an idea what’s going on, as I just enabled CAPONE on a FOG installation yesterday and had some issues as well.

    I did the same as you, adding the boot menu text into PXE Boot Menu page on the webserver, but for some reason, the page isn’t separating the text properly. IF you have physical access to the fog server, I would suggest doing this:

    [I]At the fog server, open a terminal (this may vary depending on your flavor of Linux, I’ll assume you know how to get this far. [/I]

    At the Terminal:

    [CODE]sudo nano /tftpboot/pxelinux.cfg/default[/CODE]

    Use the arrow keys to browse to the line of text that starts with [B]“LABEL Capone”[/B]

    If I am correct, then the line starting with “LABEL Capone” also has the words “kernel” and several other parts of text next to it. We need to separate these lines.

    There should be 3 main lines. One Beginning with “LABEL CAPONE”, one with “KERNEL”, and then a final one with “APPEND”. I’ve included my Capone listing so you can see what I mean.

    [CODE]LABEL capone
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=<dns> mode=capone ftp=<fog_ip> storage=<fog_ip>:/images/ web=<fog_ip>:/fog/ shutdown=on loglevel=4[/CODE]

    the append line must not be separated at any point, from “Append” to “loglevel=4” is one solid line, but the key is separating the LABEL line and kernel line.

    After you make edits in the file above, hit CTRL+X and then y to confirm you want to save the file.

    Hopefully this helps!



  • Sid,

    In the fog settings, there is Capone setting section.
    Set the:
    [SIZE=13px][FONT=Ubuntu][COLOR=#333333]FOG_PLUGIN_CAPONE_DMI to system-product-name

    Hope it helps,

    Tom[/COLOR][/FONT][/SIZE]



  • I made up a password and typed it in as Master Password and the Capone showed up, but nothing happens when I select the capone in Pxe menu.
    I assocciated the System Product Name to the Capone, but it won’t do anything in PXE menu.
    any Idea?
    Thanks



  • Sounds like your PXE menu didn’t get saved, make sure you fill in the “Master password” when your editing anything on the “PXE Boot Menu” page.


Log in to reply
 

420
Online

38955
Users

10706
Topics

101578
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.