Could you add Wake-On-Lan Activation/Desactivation ?



  • Hi there,

    In my lan, all my HP don’t boot on lan when awakenb by wake-on-lan signal even if configured to boot first on network… bug or not, i can’t do anything, so, automaticaly wake-on-lan don’t help because i had to reboot manually computers. Could you please add a checkbox in the create task options to desactivate the wol when we start the task ? (like the schedule shutdown one).



  • Yes, that was this option help me to find out how to deactivate it… but, my request was to avoid deactivate for all, just for computers that are bugging with that. All of mine this case but i certainly will have the case that some will works and others not. A by group WOL activation should be really cool.


  • Senior Developer

    You can detach FOG from WOL by changing the wol request path.

    This is found in FOG Configuration->FOG Settings->General Settings->FOG_WOL_PATH

    Just unset the path and while things will try to send, it can’t find the path essentially meaning it will not wake up the host.



  • Yes but in HP bios, this is misery… no configuration. Just boot order, so forced WOL from FOG is annoying and i need to keep BIOS WOL activated for some reasons. That’s why i asked an option to deactivate auto wol signal from fog when launching task because it is a nonsense to wol computers when launching task that need them to boot on lan when it don’t work. I’m not sure to be clear… ?


  • Moderator

    @Jean-Jacques-Morda Hi, it’s not a FOG problem/feature, it’s BIOS configuration : WOL is not WOL+LAN boot auto ;)



  • You don’t understand. Wake On Lan is working and wake up computers.

    Well here is the problem :

    Boot order in the computer bios :

    1-LAN
    2-HD

    When i switch on manually the computer, it will boot on LAN, no problem.
    When the computers are waking up by wake on lan, it directly boot on HD not on LAN.

    So, when i launch a task in fog, it switch on all my computers an none of them boot on lan to launch the fog task, that is a nonsense.

    So, i hope to have a trick to switch off WOL function in FOG when launching task instead of editing manually the wol.php file to bypass the try procedure. Peharps i’m wrong and the trick is existing in fog but i didn’t noticed it yet.


  • Senior Developer

    I guess I am not understanding this request. If wake on LAN isn’t working, have you tried the wolbroadcast plugin? Adding another option isn’t all that difficult, but making one that doesn’t allow wol packets seems a bit strange. Wol only happens if a tasking hasn’t been checked in. It is only sent on port 9, unless somebody else changed the port, and is only sent on udp. If a host isn’t starting automatically, what’s the reason for deactivating it at the host? It isn’t working anyway you know?


Log in to reply
 

400
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.